Opened 3 years ago

Closed 8 months ago

Last modified 8 months ago

#13102 closed defect (fixed)

SCUMM/HE - Crackling on start of every new music piece

Reported by: raziel- Owned by: AndywinXp
Priority: high Component: Audio
Version: Keywords:
Cc: Game: Freddi Fish 4

Description

ScummVM 2.6.0git (Nov 22 2021 10:17:09)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL

From the save game, move right to another screen (do that back and forth) to hear a really laud crackling on start of the new ambient music piece.

This happens all over the game, whenever there is another music started, the crackling can be heard first.

Freddi Fish 4: The Case of the Hogfish Rustlers of Briny Gulch (Windows)

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 11.1.0) 11.1.0

Attachments (1)

freddi4-win-Freddi4.sg3 (30.1 KB ) - added by raziel- 3 years ago.

Download all attachments as: .zip

Change History (9)

by raziel-, 3 years ago

Attachment: freddi4-win-Freddi4.sg3 added

comment:1 by aquadran, 2 years ago

Summary: AUDIO: Freddi Fish 4 - Crackling on start of every new music pieceSCUMM/HE - Crackling on start of every new music piece

comment:2 by Thunderforge, 2 years ago

Reproduced on 2.6.0 (Windows x64) and the US Steam version of the game. I don't know I would describe it as a "really loud crackling", but there is definitely a "thump" sound, almost like someone tapping on a microphone. It's not particularly loud and had I not been looking for it, I probably would have ignored it.

comment:3 by raziel-, 2 years ago

An even easier method to reproduce

  • load the savegame
  • click on the "computer" bubble (in-game save/load)
  • click on "Cancel" (return arrow)

Everytime you get back into the game, the main theme of the scene will be load and an audible "thud" can be heard.

comment:4 by raziel-, 14 months ago

You can also swim to the left and back to the right from the save game (two different music pieces)
The "crackling" became a loud "thud" (@Thunderforge) in the meantime for me as well.
But it "is" really audible.

Could the music data been read from position -1 instead of 0, maybe (regression)?

comment:5 by sev-, 8 months ago

Priority: normalhigh

It would be nice to get it fixed before the 2.8.0 release.

comment:6 by AndywinXp, 8 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

Well would you look at that... a leftover development header block which is being played as audio data :-)

Fixed on master!

comment:7 by raziel-, 8 months ago

Nice...thank you 😀

comment:8 by SomeRandomHEFan, 8 months ago

This isn't the only game where HE let faulty headers slip into the audio data. I remember some of the music in Putt-Putt Travels Through Time having this issue as well. And the initial 1996 release of Pajama Sam 1 had two voice clips with clicks at the start when you pick up the oil can. There's probably more, but that's all I can remember.

Looking at the code for the fix, it seems it specifically checks for the presence of an unwanted SRFS header, so maybe some of the clicks in other games were already fixed by this as well. In that case, perhaps the comment explaining the fix should be rewritten.

If there's interest, I can go through extracted audio for other HE games and see if I find any more clicks as well as if they're caused by the same header or a different one.

Last edited 8 months ago by SomeRandomHEFan (previous) (diff)
Note: See TracTickets for help on using tickets.