Opened 11 months ago

Closed 4 months ago

#13075 closed defect (duplicate)

MACOS: OpenGL - Mouse cursor gets stuck around the edges in fullscreen mode

Reported by: dfabulich Owned by: criezy
Priority: normal Component: Port: Mac OS X
Version: Keywords: Mouse, Sticky, Stuck, Fullscreen, OpenGL
Cc: dfabulich Game:

Description

In ScummVM 2.5.0, in all games, in full screen mode, if I move my mouse cursor near the edge of the screen, the mouse cursor gets "stuck" there, unable to leave the edge of the screen.

This is a regression from ScummVM 2.2.0.

I'm attaching a screen recording of the problem. I've reproduced this problem in several different games in several different engines:

  • Day of the Tentacle (CD/English)
  • Myst (Masterpiece Edition/Windows/English)
  • Quest for Glory II: Trial by Fire (DOS/English)

I'm on macOS Monterey 12.0.1. I've reproduced this issue on an Intel MacBook Pro (16-inch, 2019) and on an M1 MacBook Pro (16-inch, 2021), which are both HiDPI machines. I'm not able to reproduce this problem on a Windows 10 VM running on my Intel MacBook Pro, so the problem appears to be specific to macOS.

Change History (10)

comment:1 by dfabulich, 11 months ago

My screen recording is too large to upload as an attachment. Here's a YouTube video of the repro. https://www.youtube.com/watch?v=ITJqtOkNjuQ

comment:2 by dfabulich, 11 months ago

Following this forum thread, I switched my graphics mode to "SDL Surface" the bug went away on both of my test machines. The bug appears when I select "<default>" or "OpenGL" graphics modes.

comment:3 by dfabulich, 11 months ago

Keywords: OpenGL added
Summary: macOS: Mouse cursor gets stuck around the edges in fullscreen modemacOS/OpenGL: Mouse cursor gets stuck around the edges in fullscreen mode

comment:4 by dfabulich, 11 months ago

Component: CommonPort: Mac OS X

See also https://bugs.scummvm.org/ticket/12822

Note that #12822 required enabling Aspect Ratio Correction. I'm using stock ScummVM settings, which does not enable AR Correction, and I find that enabling/disabling AR Correction doesn't help/hurt this issue in OpenGL mode.

Last edited 11 months ago by dfabulich (previous) (diff)

comment:5 by criezy, 11 months ago

Bug #12822 did not actually require turning aspect ratio correction on to occur. It required having Pilar boxes, which can also happen with aspect ratio correction turned off. But that bug was fixed in the 2.5.0 release already anyway.

The bug you describe here sounds like it may however be related to bug #12646, or maybe even be the same bug. Sadly I have never been able to reproduce such issue.

comment:6 by dfabulich, 11 months ago

Well, I’m prepared to provide any additional information you need to fix this, including setting up a dev environment, making an appointment to screen share, or providing additional logs or whatever.

comment:7 by sev-, 10 months ago

Priority: highnormal

comment:8 by kalkie, 8 months ago

This is very likely a duplicate of #12646. I've submitted a PR for that issue:
https://github.com/scummvm/scummvm/pull/3699

For more information, see comment:7:ticket:12646.

comment:9 by aquadran, 4 months ago

Summary: macOS/OpenGL: Mouse cursor gets stuck around the edges in fullscreen modeMACOS: OpenGL - Mouse cursor gets stuck around the edges in fullscreen mode

comment:10 by criezy, 4 months ago

Owner: set to criezy
Resolution: duplicate
Status: newclosed

Since we suspect this is a duplicate of bug #12646 that has now been fixed, I will close this one as well. Feel free to reopen if it turns out this issue is a different one and still occurs.

Note: See TracTickets for help on using tickets.