Opened 9 months ago

Closed 9 months ago

#13072 closed defect (fixed)

BLADERUNNER: Broken Officer Leary talk animations

Reported by: jakejakejake123 Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Version: Keywords:
Cc: Game: Blade Runner

Description

In the original version of the blade runner game Officer Leary moved his arms around when he talked just like all the others characters in the game. But for some reason in the restored content version he just stands completely still when he talks. His animations seem to be broken and they need to be fixed.

Change History (2)

comment:1 by antoniou79, 9 months ago

Component: --Unset--Engine: Bladerunner
Game: Blade Runner
Owner: set to antoniou79
Resolution: fixed
Status: newpending
Summary: Blade runner restored content bug - Broken Officer Leary animations.BLADERUNNER: Broken Officer Leary talk animations

I've committed a fix for this here:
https://github.com/scummvm/scummvm/commit/4c8c5f12faaa315d71204f11eb4f23dffc6267f7

It should now work as intended.

If possible, please check with a fresh build from master branch, or a daily dev build (starting from tomorrow, when the new dailies will be ready)

comment:2 by antoniou79, 9 months ago

Status: pendingclosed

I just tested with an development build from our buildbot.
I should note that the bug affected both the vanilla and restored content mode (it was not specific to restored content).

The issue is fixed, so I'm closing the ticket.

Note: See TracTickets for help on using tickets.