Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#13060 closed defect (fixed)

BMP regression: QFG4 AVI files play upside down

Reported by: Terelyn Owned by: sluicebox
Priority: normal Component: Graphics
Version: Keywords:
Cc: Game: Quest for Glory 4

Description

FLYBY.AVI plays upside down in Quest for Glory IV: Shadows of Darkness (CD/Windows/English) when launched through ScummVM.

Change History (4)

comment:1 by sluicebox, 11 months ago

Component: Engine: SCIGraphics
Summary: The intro video plays upside down in Quest for Glory IV: Shadows of Darkness (CD/Windows/English)BMP regression: QFG4 AVI files play upside down

Yikes! Great catch, thank you. Changes were made to the BMP parser a few days ago, this is caused by: https://github.com/scummvm/scummvm/commit/5d093e725fd6832280d0865abdb685e41bf3efda

comment:2 by sluicebox, 11 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

in reply to:  2 comment:3 by Terelyn, 11 months ago

Replying to sluicebox:

Fixed in: https://github.com/scummvm/scummvm/commit/620dc8a1df3c81742b28461733b5f21d8e69c642

Thanks, it's working perfectly. Small correction, the ticket number is #13060, not #13059.

comment:4 by sluicebox, 11 months ago

Another of my mistakes committed to eternity!

Note: See TracTickets for help on using tickets.