Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#13045 closed defect (fixed)

Quest for Glory III: Wages of War crashes if i press the Enter key in the main menu

Reported by: Terelyn Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Quest for Glory 3

Description

If i press the Enter key in the main menu, the game crashes and the following message appears in the console. :

ERROR: Uninitialized read for temp 58 from method IconBar::dispatchEvent (room 130, script 937, localCall ffffffff)!

Change History (7)

comment:1 by Terelyn, 8 months ago

Summary: Quest for Glory III: Wages of War crashes if i press Enter in the main menuQuest for Glory III: Wages of War crashes if i press the Enter key in the main menu

comment:2 by sluicebox, 8 months ago

Thanks for reporting this. I can reproduce, this is a script bug in the game. I'll take a look soon.

comment:3 by sluicebox, 8 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in https://github.com/scummvm/scummvm/commit/ab20c9bee27b6afda04e0ab0810a40a573ef8ab5

This will appear in the next daily build.

Thanks again!

in reply to:  3 comment:4 by Terelyn, 8 months ago

Replying to sluicebox:

Fixed in https://github.com/scummvm/scummvm/commit/ab20c9bee27b6afda04e0ab0810a40a573ef8ab5

This will appear in the next daily build.

Thanks again!

Hi!
Sorry, apperently i only reported the error with the "Restore Game" button. It still crashes the game with different error messages, depending on the selected icon bar when you press Enter.

Last edited 8 months ago by Terelyn (previous) (diff)

comment:5 by sluicebox, 8 months ago

Thanks for trying it out, sounds like we need some more details. First, what version of ScummVM are you using? (or maybe you're building from source?) I ask because my change may not be in the latest daily build yet.

I was able to trip the error before but only once, it doesn't happen every time. You seem to be getting it reliably, can you provide exact instructions on what you're doing with keyboard and mouse to reproduce this? (Starting from launching the game)

Also, which version of QFG3 do you have? It will tell you the version number in the game's control panel when you click the Sierra logo.

comment:6 by Terelyn, 8 months ago

I'm using the latest daily build of ScummVM. Also steam version of Quest for Glory 3 (DOS).

Okay, i was able to reliably reproduce it.

  1. Select a button in the main menu with the cursor.
  2. Move away the cursor from it sideways, then press Enter.
  3. It should crash the game with the exception of "Play Game" "Restore Game" (these work fine) and "Quit" (it doesn't respond, though). It crashes with "Create Character" and "Import Character", too.

The game otherwise works fine.

Last edited 8 months ago by Terelyn (previous) (diff)
Note: See TracTickets for help on using tickets.