Opened 2 years ago

Closed 8 months ago

#13041 closed defect (worksforme)

DRAGONS: Catapult Mandatory Minigame Not Working

Reported by: Zimgief Owned by: tag2015
Priority: normal Component: Engine: Dragons
Version: Keywords:
Cc: Game: Blazing Dragons

Description (last modified by Zimgief)

The catapult minigame doesn't start correctly: the player can be moved but not target appears. The mini-game is mandatory, and the player can not even exit it, as it is supposed to end 10 targets appeared.

Furthermore, the aiming is off, at least visually, as the cat is not lauched higher as the left mouse button is hold, but it does crash or traverse the walls depending on the duration of the input (in other words : it seems to react accordingly, but the visuals do not reflect that).

Tested on Windows 10 64 bits build 20H2. ScummVM 2.2, 2.5 and daily build from 26 october 2021.

Blazing Dragon is the US PS1 version.

Attachments (1)

dragons-us.001 (20.1 KB ) - added by Zimgief 2 years ago.

Download all attachments as: .zip

Change History (7)

by Zimgief, 2 years ago

Attachment: dragons-us.001 added

comment:1 by Zimgief, 2 years ago

Description: modified (diff)

comment:2 by Zimgief, 2 years ago

Description: modified (diff)

comment:3 by sev-, 2 years ago

Priority: blockernormal
Summary: Catapult Mandatory Minigame Not WorkingDRAGONS: Catapult Mandatory Minigame Not Working

comment:4 by tag2015, 11 months ago

Could you try again with a recent ScummVM build? Using your save I can start (and complete) the minigame normally.

comment:5 by tag2015, 8 months ago

No answer from the OP, and I can't reproduce the problem.
I'm using the same version on win10, tried with different graphics settings and with mouse+keyboard or controller.

I recorded a playthrough of the minigame using the provided save:
https://www.youtube.com/watch?v=4XxKs20UWsU

Closing for now, please reopen if needed

comment:6 by tag2015, 8 months ago

Owner: set to tag2015
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.