Opened 7 months ago

Closed 20 hours ago

#13013 closed defect (fixed)

BACKENDS: SDL: Cursor is sticky around the edges on WAYLAND

Reported by: vanfanel Owned by: ccawley2011
Priority: normal Component: Port: Linux
Version: Keywords: Mouse, Sticky, Linux, Wayland, SDL2, Backend
Cc: vanfanel Game:

Description (last modified by vanfanel)

Hi there,

I have recently been using Scummvm (latest GIT code build) on WAYLAND, the new graphics server currently becoming the default on many GNU/Linux distros by now.

The problem is that the mouse cursor in fullscreen mode, when a game doesn't fill the entire screen area, is sticky around the edges.
That happens because the internal cursor position goes beyond the game area, which shouldn't happen.
Scummvm uses SDL_WarpMouseInWindow() to avoid this, which seems to be non-working on WAYLAND, hence the problem happens.

There's also a thread on SDL2 development repository to discuss this Scummvm issue, and SDL2 WAYLAND backend devs apparently think that SDL_WarpMouseInWindow() shouldn't be used:
https://github.com/libsdl-org/SDL/issues/4822

Change History (3)

comment:1 by vanfanel, 7 months ago

Description: modified (diff)

comment:2 by sev-, 7 months ago

Summary: [Backends] [SDL] Cursor is sticky around the edges on WAYLANDBACKENDS: SDL: Cursor is sticky around the edges on WAYLAND

comment:3 by lephilousophe, 20 hours ago

Owner: set to ccawley2011
Resolution: fixed
Status: newclosed

This should be fixed in current master.
The PR #3546 handles the problem.

Note: See TracTickets for help on using tickets.