Opened 3 months ago

Closed 3 months ago

#13011 closed defect (invalid)

ScummVM 2.5.0 MI1 SE Talkie Edition audio issue

Reported by: bluddy Owned by: antoniou79
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 1

Description

Running my Talkie Edition on 2.5.0, it seems like ScummVM no longer knows how to locate the correct audio files.
As soon as I run the game, I get the message that "This game has audio tracks on its CD...for details". I then believe that it defaults to midi tracks.

In terms of speech, the audio is played correctly.

Change History (3)

comment:1 by antoniou79, 3 months ago

I cannot seem to reproduce this.

I tested with ScummVM 2.5.0 and 2.6.0git on Windows 10 x64.

I have the latest 1.02 version of the Talkie Edition ( MI1_Ultimate_Talkie_Edition_1.02), which I built today from the Steam version. I used the "flac" option for music.

The Talkie Edition created two subfolders; one is "cd_music_flac", the other is "se_music_flac". If I explicitly point ScummVM to use either as an "Extra Path" for this game, this seems to work and use that specific set of music files. Also the option to move audio files for environmental sounds (via extended_SE_tracks_to_game_folder.bat) in the main game folder works too in this case. Those will then play either in CD audio or SE music mode.

By default, if the Extra Path is empty, I'll get the warning message about audio tracks from CD missing, which is the default message for when using the classic version files directly extracted from the SE resources, with no ripped music in the game folder. These (original classic version) files do not contain midi or any type of music on their own. However, in the case for the data files that the Talkie Edition creates, the classic version files have been modified to support MIDI (and MT-32!) so ScummVM will play music, even if it displays the warning message. (The moved environmental audio tracks will not play in this case however). So, we probably shouldn't show this warning for this case -- although it does hint to the user that the "improved" soundtrack (whether it's CD or SE music) is not used. Maybe we'd need a specially adjusted message just for this case (?)

The Readme file from the MI1_Ultimate_Talkie_Edition_1.02 (under "Playing it with ScummVM") states:

Hint: If you prefer MIDI mode without any additional soundtrack, you can get rid of the ripping reminder by just putting a silent dummy track1 into the game folder.

So the warning message is "expected" and they suggest a workaround if the user is knowingly settling for the MIDI mode music.

The installation process (in the ReadMe file) does mention setting the Extra Path:

  • Now add the game as usual, plus the extra path of the music version of your choice.

Maybe the issue is with .ogg files?
Also, I'm not sure about this; did ScummVM use to by default check for specifically named subfolders to find extracted music files in them?

Last edited 3 months ago by antoniou79 (previous) (diff)

comment:2 by bluddy, 3 months ago

Ah OK. It seems that the Talkie version used to work (at some point) without the Extra path. Once I added the path it started playing correctly.

comment:3 by antoniou79, 3 months ago

Owner: set to antoniou79
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.