Opened 5 days ago

Closed 3 days ago

#13007 closed defect (fixed)

SCI: Hoyle Classic Card Games - overriding global audio settings disables digital voice samples

Reported by: Thelypody Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Hoyle's Classic Card Games

Description

Hoyle Classic Card Games (hoyle4) features short digitized voice samples which play sometimes during gameplay. Currently clicking the checkbox "Override global audio settings" for this game in ScummVM launcher somehow disables these voice samples, even if you leave everything else in Audio tab set to default.

Steps to reproduce:
1) Check the "Override global audio settings" checkbox in game's Audio settings tab.
2) Launch the game and start a Crazy Eights match
3) After a while an opponent will play an 8 card and announce a suit change with a speech bubble. This is supposed to be voiced.

ScummVM 2.5.0
Windows 10 20H2 64-bit

Change History (2)

comment:1 by sluicebox, 5 days ago

Owner: set to sluicebox
Resolution: pending
Status: newpending

Thanks for reporting this; great catch. I've confirmed this and it looks like an issue with the audio options screen. Though I'm partial to testing with Gin Rummy =)

I have a fix, I'll PR it soon.

This would apply to any other SCI game that we have marked as GUIO_NOSPEECH (so, a floppy version) thatuses the speech functions for a handful of messages... but Hoyle4 might be the only one that does that. I checked EcoQuest 2 ("Hey, watch the suit!" in the first room) but that's just a regular sound effect they play in the background.

comment:2 by sluicebox, 3 days ago

Resolution: pendingfixed
Status: pendingclosed

Fixed in 44245eebbcce16bed769cf77b894eeecbeda94ad and 68ba0fa2d6c5bc518b31d4a65d093cb803abe4f3. This will appear in the next daily build: https://www.scummvm.org/downloads/#daily

There were two things going on:

  1. Hoyle4 was marked as having No Speech, which disabled the Speech/Subtitles/Both toggle when Override was selected. But Hoyle4 does have some speech.
  2. The options screen was using values from the disabled toggle controls.

Both of those are now fixed. Once you have a version with these fixes, I recommend removing and re-adding Hoyle4 to ScummVM. That will make the toggle enabled when you select Override and you can make sure it's not set to Subtitles, as that mutes speech in SCI games.

Note: See TracTickets for help on using tickets.