Opened 2 weeks ago

Closed 13 days ago

#13000 closed defect (fixed)

XEEN: Outright crash when starting game

Reported by: GermanTribun Owned by: dreammaster
Priority: high Component: Engine: Xeen
Version: Keywords:
Cc: Game: Might and Magic: World of Xeen

Description

ScummVM: 2.5.0
System: Windows 10 x64
Game version: German Floppy version

When trying to start WoX with the new 2.5.0 version of ScummVM, the game crashes outright before even properly starting, which is especially irritating, since it did start with version 2.2.0.

The error message given by the console is attached as a graphics file.

Attachments (1)

scummvm-worldofxeen-de-00000.png (5.5 KB ) - added by GermanTribun 2 weeks ago.

Download all attachments as: .zip

Change History (8)

by GermanTribun, 2 weeks ago

comment:1 by criezy, 2 weeks ago

This is similar to bug #12985 but not exactly the same bug.
From what I can see in the history, when support for the Russian version was added three months ago, this broke all the other localised versions (French, German, ...). I think the fix for bug #12985 should also fix this bug though.

You can try a stable daily build, which should already have the fix. Please let us know if that version works.

That being said it looks like all the German versions are marked as unstable in the detection, so I don't know how well they work. But it should at least start with the fix that was made.

comment:2 by GermanTribun, 2 weeks ago

Well, the last daily built was from October 1st (it rads 2.3 Opre), so that doesn't help me much. Somehow the builds have not updated on the website for some time.

Last edited 2 weeks ago by GermanTribun (previous) (diff)

comment:3 by criezy, 2 weeks ago

The daily builds I see on https://buildbot.scummvm.org/#/dailybuilds are from this morning. But I guess you must be looking somewhere else...

That being said the fix for WoX was actually made this morning and is not yet included in the last daily build. It should be included in the next one tomorrow morning.

comment:4 by GermanTribun, 2 weeks ago

Which one is the correct one? Branch Master or Future 2.5.X? It's the first time I use this one, before I always got daily builds from the scummvm page.

comment:5 by criezy, 2 weeks ago

I suggested "stable" in my previous message, which would be Future 2.5.X. But the fix has been pushed to both, so either one should work (if you wait until tomorrow for the next build).

comment:6 by GermanTribun, 2 weeks ago

Thanks, now it works.

Of course there are other issues I noticed right away (like with the sound engine, wrong intro behavior, wrong timing...) but that will be sperate reports.

comment:7 by criezy, 13 days ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Thanks for testing.

Note: See TracTickets for help on using tickets.