Opened 2 years ago

Closed 3 months ago

#12998 closed defect (fixed)

AGS: Quest for Glory II: Trial by Fire Remake - Toolbar icons often glitch on click

Reported by: Thelypody Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords: mouse
Cc: OmerMor, Smelltastic, lwcorp Game: Quest for Glory 2

Description (last modified by Thelypody)

Quest for Glory II: Trial by Fire Remake features a top toolbar similar to Sierra's VGA games in the series. Clicking on any of the left five buttons often produces a bug where the toolbar just disappears for a split second instead of registering a click and switching cursor action. This is extremely annoying in case of the fifth button, Special Actions, as instead of opening an additional menu it just moves the cursor closer to the middle of the screen where it expects a new button row to appear. Interestingly this does not affect the right five buttons starting from the sixth Magic button.

Steps to reproduce:
1) Create a new character and start a game
2) Click on any of the top left five buttons

ScummVM 2.5.0
Windows 10 20H2 64-bit

Attachments (4)

QFG2 VGA can't click actions.mp4 (1.0 MB ) - added by lwcorp 12 months ago.
Video clip of not being able to click the action menu
image-20230526-012153.png (170.5 KB ) - added by lwcorp 9 months ago.
Icon position after clicking Special Actions
QFG2 VGA hard to click actions.mp4 (1.9 MB ) - added by lwcorp 7 months ago.
Depending on the angle, even simple actions are semi-unclickable
image-20230805-111312.png (21.8 KB ) - added by lwcorp 7 months ago.
The angle of clicking basic actions makes all the difference

Change History (36)

comment:1 by Thelypody, 2 years ago

Upon further examination, the same issue also happens in all AGDI's King's Quest remakes.

comment:2 by Thelypody, 2 years ago

Description: modified (diff)

comment:3 by danaith1234, 2 years ago

I have the exact same issue. sometimes i get lucky and it actually appears. otherwise it glitches. almost seems like it wants to pull up but just doesnt, maybe a speed issue, it seems to quick to catch the bar

comment:4 by danaith1234, 2 years ago

i have found an odd "workaround" if you click on the special action bar, then quickly move your mouse down(and i mean quickly) itll catch the pop up menu. it still doesnt work everytime but i can get it down to ALMOST work every time

comment:5 by OmerMor, 2 years ago

Cc: OmerMor added

comment:6 by Smelltastic, 2 years ago

I came into these forums to post a bug with the QfG2 VGA remake that the Special Action button, to bring up the walk/run/sneak/status etc page, wouldn't open. I believe it's this same issue. When I swipe down quickly while pressing the button I can get it to come up, like OmerMor posted (thank you!).

What's weird is that for me, all the other buttons seem to work fine, including the magic, inventory, and system menus. Only that one button consistently has the issue for me.

comment:7 by Smelltastic, 2 years ago

Cc: Smelltastic added

comment:8 by bliznik, 2 years ago

Thanks for opening this ticket. Also, thanks for the workaround! On a related note, you don't need to "quickly" move your mouse, you can simply left-click and drag your mouse pointer down to where the Special Action menu should pop up. If you release your left-click in the correct area (to overlap with the special menu), then you can access the menu.

I am guessing that, when you click on the icon, the game pulls up the special menu. If your mouse location overlaps with the special menu, the special menu will stay on the screen. But if your mouse location does not overlap with the special menu, the game closes the special menu.

In the original AGD Interactive version, after the game activates the special menu, it relocates your mouse location to a location over the special menu. In ScummVM, after the game activates the special menu, your mouse location does not move. So, the game will automatically close the special menu immediately after opening it since it detects that your mouse pointer location does not overlap with the special menu. In order to fix this bug, a programmer will probably need to create a special instruction just for games like this one, which will relocate the mouse pointer location to a location that overlaps with the special menu upon activation of the special menu.

Last edited 2 years ago by bliznik (previous) (diff)

comment:9 by lwcorp, 23 months ago

Game: Quest for Glory 2

comment:10 by i30817, 23 months ago

It's probably better to open this in upstream if it happens there, since that dev is more active.

Upstream is at: https://github.com/adventuregamestudio/ags/issues

in reply to:  10 comment:11 by bliznik, 23 months ago

Replying to i30817:

It's probably better to open this in upstream if it happens there, since that dev is more active.

Upstream is at: https://github.com/adventuregamestudio/ags/issues

Huh? Does Upstream fix bugs that occur only in ScummVM and not anywhere else? This is an issue that only occurs when you play the game using ScummVM. This issue doesn't occur if you play the game using the normal executable.

comment:12 by i30817, 23 months ago

I just tested current ags with the game and you're right. I just suggested because ags often has regressions.

But i found other problems to report in this game there so, i'm going to do that now.

comment:13 by i30817, 23 months ago

BTW i also tested in a self compiled scummvm executable (not libretro or any other port) and it had no such problem here so i don't know what's happening.

comment:14 by i30817, 23 months ago

Ok i just tested the libretro scummvm core (updated version based on upstream master here: https://github.com/diablodiab/libretro-scummvm-backend with one of the patches in the bug report page there to make mouse cursor work on some other games) and i noticed the problem reported here so i'm testing if i can reproduce after pulling the latest scummvm code and testing with that backend again.

Last edited 23 months ago by i30817 (previous) (diff)

comment:15 by i30817, 23 months ago

Yup, happens there for some reason. Although it happens 'once' (the main cursor doesn't appear to change - although if you move out of the bar it does - and the bar flashes once) and then if you click a second time it works 'correctly' (the main cursor changes even on top of the bar, the bar doesn't flash), then it repeats.

Note that in scummvm the bar actually disappears completely the first time. I think the 'problem' here is that the bar was supposed to disappear to show the icon (moving the cursor down if it was in the original bar hotspot) but it only happens the second time. The skill button doesn't even do anything if you're not 'above the area the cursor would be moved to.

It's kind of weird this is happens to me only on the libretro core - especially this version which is using upstream code instead of being thousands of commits behind.

Last edited 23 months ago by i30817 (previous) (diff)

comment:16 by i30817, 23 months ago

I opened bugs for this in

ags (this is also about broken buttons i noticed): https://github.com/adventuregamestudio/ags/issues/1610

and in the scummvm backend core: https://github.com/diablodiab/libretro-scummvm-backend/issues/7

Just to keep track if it's fixed in one of these places.

comment:17 by i30817, 22 months ago

BTW, this engine shows another bug in heroine's quest (in scummvm not in upstream ags) where thrivaldi portrait appears midway through the intro as if it was 'speaking' after thrivaldi does a fist shaking animation. This doesn't happen (anymore i guess) in upstream ags. I'll open a bug for it.

Last edited 22 months ago by i30817 (previous) (diff)

comment:18 by tag2015, 13 months ago

The relative upstream fix was merged some time ago. I tested some of the AGDI games and I can't see any issue now with the toolbar and icons.

Closing

comment:19 by tag2015, 13 months ago

Resolution: fixed
Status: newclosed

by lwcorp, 12 months ago

Video clip of not being able to click the action menu

comment:20 by lwcorp, 12 months ago

Resolution: fixed
Status: closednew

Reopened since it wasn't even fixed in the game it was reported on.

Attached video clip to see it still happens in the latest v2.8.0git1874-gc7c2141d0a8 (Feb 27 2023 05:02:05) + the newly released v2.7.0.

comment:21 by tag2015, 11 months ago

This bug is interesting...
The issue does indeed happen with builds downloaded from the website, but it works perfectly fine on my MSYS2-MinGW64 builds on Win10. So I think the bug could be related to some library or optimization, not to the AGS engine itself.

comment:22 by tag2015, 10 months ago

@lwcorp could you please check if the bug still occurs using the daily development build?
https://buildbot.scummvm.org/#/dailybuilds

Thanks!

by lwcorp, 9 months ago

Attachment: image-20230526-012153.png added

Icon position after clicking Special Actions

in reply to:  22 ; comment:23 by lwcorp, 9 months ago

Replying to tag2015:

@lwcorp could you please check if the bug still occurs using the daily development build?

Sure, I've tried ScummVM 2.8.0git4983-g4374f1458b0 (May 25 2023 04:57:39) and all buttons are clickable now, thanks!!!

However, there's still an issue: after clicking the special actions, the icon suddenly "teleports" into the bottom right corner of the submenu. It's not even inside the submenu but below it. This behavior feels like losing control over your mouse and then going to track it in an unnatural location.

If I compare it to the original QFG VGA games inside ScummVM (see a screenshot):

  • In QFG4 after clicking special actions, the icon remains in the same place you clicked it.
  • In QFG3 and QFG1VGA after clicking special actions, the icon does teleport like in here, but at least it teleports to the middle of the submenu which is much more noticeable and available for immediate use. BTW, QFG1VGA is better than QFG3 in this regard because in QFG1VGA the icon is inside the submenu, whereas in QFG3 it's slightly under it (although it's just visual and still clickable).
Last edited 9 months ago by lwcorp (previous) (diff)

in reply to:  23 comment:24 by tag2015, 9 months ago

Sure, I've tried ScummVM 2.8.0git4983-g4374f1458b0 (May 25 2023 04:57:39) and all buttons are clickable now, thanks!!!

Glad that now it works :)

However, there's still an issue: after clicking the special actions, the icon suddenly "teleports" into the bottom right corner of the submenu. It's not even inside the submenu but below it. This behavior feels like losing control over your mouse and then going to track it in an unnatural location.

That's how the developers designed it, if you run the game using the original executable it behaves the same way (at least that's what happens on my system). In general we don't introduce changes to the games beviour unless it's an important bugfix, to be faithful to the originals.

If I compare it to the original QFG VGA games inside ScummVM (see a screenshot):

  • In QFG4 after clicking special actions, the icon remains in the same place you clicked it.
  • In QFG3 and QFG1VGA after clicking special actions, the icon does teleport like in here, but at least it teleports to the middle of the submenu which is much more noticeable and available for immediate use. BTW, QFG1VGA is better than QFG3 in this regard because in QFG1VGA the icon is inside the submenu, whereas in QFG3 it's slightly under it (although it's just visual and still clickable).

Well those games were made by different developers and use a different engine, so the comparison does not really mean much... such discussion would be better suited for the AGDI forum (but it's quite dead nowadays)

comment:25 by tag2015, 9 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed

Closing again (hopefully) as fixed

comment:26 by lwcorp, 7 months ago

Resolution: fixed
Status: closednew

Well, this is very disappointing. I've found myself having to re-reopen it since v2.7.1 was released days ago...without fixing it.

This is even though it was fixed in the daily development build more than 3 months ago. Actually it's even still fixed in the latest one 2.8.0git6236-gca36141f9b5 (Aug 4 2023 04:03:06). Did someone forget to push it to the main branch all these months?

In fact, it actually became worse than before since now all basic actions (walk, look, take and talk) are semi-unclickable. Clicking them leaves the menu open, meaning you can't use those icons until you manually exit the menu after clicking them.

It's perfect in the daily though, so all you have to do is take the fix from the daily.

Last edited 7 months ago by lwcorp (previous) (diff)

comment:27 by lwcorp, 7 months ago

Keywords: mouse added

in reply to:  26 comment:28 by tag2015, 7 months ago

Replying to lwcorp:

Well, this is very disappointing. I've found myself having to re-reopen it since v2.7.1 was released days ago...without fixing it.

This is not a simple "fix", there are hundreds of AGS commits between branch 2.7 and the current master (future 2.8.0). These changes are quite invasive and risked breaking various games (there are thousands of AGS games, you know).

This is even though it was fixed in the daily development build more than 3 months ago. Actually it's even still fixed in the latest one 2.8.0git6236-gca36141f9b5 (Aug 4 2023 04:03:06). Did someone forget to push it to the main branch all these months?

? There's just one main/master, from which each release is branched off and becomes the stable branch. Development and bugfixes always go to the master branch, and a selected number of commits are backported to the stable branch.

In fact, it actually became worse than before since now all basic actions (walk, look, take and talk) are semi-unclickable. Clicking them leaves the menu open, meaning you can't use those icons until you manually exit the menu after clicking them.

I can't reproduce this. On my system the situation is the same as before, the icon bar disappears immediately. But you can simply click and drag down to make it appear

It's perfect in the daily though, so all you have to do is take the fix from the daily.

Branch 2.7 is unlikely to get more updates

Leaving open for now (for 2.7.1 users potentially experiencing this bug), but then I'll close again, as the issue is solved in master

by lwcorp, 7 months ago

Depending on the angle, even simple actions are semi-unclickable

by lwcorp, 7 months ago

Attachment: image-20230805-111312.png added

The angle of clicking basic actions makes all the difference

comment:29 by lwcorp, 7 months ago

Now I get it that 2 months ago I tried a daily of 2.8.0 and not of 2.7.1. It's weird months before a new version one can only test 2 versions forward and thus the waiting time gets twice a long. Meaning even though it was fixed months before the new version, I guess it never had any chance to be part of it, and now the game might be unplayable for another year.

Yes, one can simply drag and drop but I doubt most players will bother doing it throughout an entire game.

As for basic actions, it depends on which angle you click. If you're above 50% of their height or so, then the menu remains. If you're somewhere in the lower 50% of the height, then it's fine.

comment:30 by lwcorp, 7 months ago

Cc: lwcorp added

in reply to:  29 comment:31 by tag2015, 7 months ago

Replying to lwcorp:

Now I get it that 2 months ago I tried a daily of 2.8.0 and not of 2.7.1. It's weird months before a new version one can only test 2 versions forward and thus the waiting time gets twice a long. Meaning even though it was fixed months before the new version, I guess it never had any chance to be part of it, and now the game might be unplayable for another year.

Besides the fact that 2.8 will come much sooner, release schedules are completely offtopic in this bugreport (which is already too long and contains unrelated information). If you want, you can discuss the issue on Discord or the forum.

comment:32 by tag2015, 3 months ago

Resolution: fixed
Status: newclosed

Closing again, as the issue is fixed in the upcoming version 2.8.0 (tested on Win and Android)

Note: See TracTickets for help on using tickets.