Opened 7 months ago

Closed 7 months ago

#12986 closed defect (fixed)

With Graphics mode OpenGL Scalers are hidden but popup can still be triggered

Reported by: jenshnielsen Owned by: ccawley2011
Priority: normal Component: GUI
Version: Keywords:
Cc: Game:

Description

By clicking on the blank space where the scaler option are in SDL Mode you can trigger the popup for the scaler option evne in OpenGL mode where these options are disabled

See attached screenshots for an example of the opengl and sdl options.

Attachments (2)

scummvm1.png (75.2 KB ) - added by jenshnielsen 7 months ago.
scummvm2.png (57.7 KB ) - added by jenshnielsen 7 months ago.

Download all attachments as: .zip

Change History (5)

by jenshnielsen, 7 months ago

Attachment: scummvm1.png added

by jenshnielsen, 7 months ago

Attachment: scummvm2.png added

in reply to:  description comment:1 by jenshnielsen, 7 months ago

Replying to jenshnielsen:

By clicking on the blank space where the scaler option are in SDL Mode you can trigger the popup for the scaler option evne in OpenGL mode where these options are disabled

See attached screenshots for an example of the opengl and sdl options.

Replicated in both 2.5.0 and master as of today (d8761a1bd03b7d0bf9673c54678d59988692a40b)

comment:2 by antoniou79, 7 months ago

There's already a PR for this by ccawley2011, pending review, here:

https://github.com/scummvm/scummvm/pull/3409

comment:3 by antoniou79, 7 months ago

Owner: set to ccawley2011
Resolution: fixed
Status: newclosed

ccawley2011's PR has been merged with master, and the issue is now fixed in daily builds.

Tested with today's daily build on Windows 10 (windows-x86-64-master-87b7ddc7).

Note: See TracTickets for help on using tickets.