Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#12968 closed defect (fixed)

QFG3: The entire program crashes if you try to take another Gem of the Guardian

Reported by: SemperFu Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: original
Cc: Game: Quest for Glory 3

Description (last modified by m-kiewitz)

This looks to be similar to https://bugs.scummvm.org/ticket/11411

I actually picked up a Gem and died when I first met the guardian, it did not crash then. It was actually when I came back days later and I tested doing it again that it happens now. I also just realized this is an older version of QFG (1.0) and GOG has 1.1 but I can't load my saved games from the newer on o I can't test on it but I have attached my 1.0 save.

ScummVM 2.3.0pre (Sep 13 2021 00:24:38)
Game ID: qfg3
Emulated interpreter version: SCI1.1

Detected features:


Sound type: Late SCI1
Graphics functions type: Late SCI0
Lofs type: SCI1.1
Move count type: ignore
SetCursor type: SCI1.1
PseudoMouse ability: yes
View type: VGA SCI1.1
kAnimate fastCast enabled: yes
Uses palette merging: no
Uses 16 bit color matching: no
Resource volume version: SCI1.1
Resource map version: SCI1.1
Contains selector vocabulary (vocab.997): yes
Has CantBeHere selector: yes
Game version (VERSION file): 1.0

lookupSelector: Attempt to send to non-object or invalid script. Address 0000:0000, method guardian::ignoreBlocks (room 770, script 998, localCall ffffffff)!
ERROR: lookupSelector: Attempt to send to non-object or invalid script. Address 0000:0000, method guardian::ignoreBlocks (room 770, script 998, localCall ffffffff)!

Attachments (1)

qfg3.063 (52.9 KB ) - added by SemperFu 9 months ago.

Download all attachments as: .zip

Change History (4)

by SemperFu, 9 months ago

Attachment: qfg3.063 added

comment:1 by m-kiewitz, 9 months ago

Description: modified (diff)

Can you please check using the original interpreter?

Is your version from GOG?
If so, maybe it's one of the fan patches that were (sadly) included by GOG (not required in ScummVM and actually harmful)
That was the result of the other ticket.

comment:2 by sluicebox, 9 months ago

Keywords: original added
Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Thank you for reporting this and attaching a save. Fixed in: 6ef5aaec6e2b9883be16da54fbf06bdef2629531 -- the fix will be in next daily build. Just barely in time for the upcoming release! =)

This is a script bug in all versions of QFG3. It's unrelated to bug #11411, it's just a coincidence that they're so remarkably close to each other. Bug #11411 was a bug in a fan patch which GOG includes.

Actually, this is script bug in the underlying Actor class that all games include. This is the only QFG3 room that uses this "blocks" feature which contains the bug. Sierra fixed this in other games soon afterwards. For example, the bug is in KQ6 floppy but fixed in KQ6 CD. (KQ6 is unaffected because it doesn't use "blocks")

comment:3 by SemperFu, 9 months ago

Just tested daily build and confirmed. Thank you for the quick fix!

Note: See TracTickets for help on using tickets.