Opened 3 years ago

Closed 17 months ago

Last modified 17 months ago

#12949 closed defect (fixed)

AGS: Whispers of a Machine - Smart Scan text is off the screen

Reported by: Thunderforge Owned by: criezy
Priority: low Component: Engine: AGS
Version: Keywords: whispersofamachine
Cc: Game:

Description

When using the Smart Scan feature, the text that appears describing the results off the left side of the screen. See attached screenshot

Version

  • Whispers of a Machine 1.0.6
  • ScummVM Daily 2021-09-21

Attachments (1)

Smart Scan Results Off Screen.png (1.4 MB ) - added by Thunderforge 3 years ago.

Download all attachments as: .zip

Change History (8)

by Thunderforge, 3 years ago

comment:1 by dreammaster, 3 years ago

This also seems to be a problem in the stand-alone AGS. Since we already know the game had custom changes (see the title screen shows some background at the bottom), this is also more than likely due to custom changes in the engine.

comment:2 by i30817, 21 months ago

This was fixed upstream with a special case for that engine. Some partial fixing of these two games (kathy rain and whispers of a machine) was done by criezy upstream and here, but after he paused merging with upstream, further changes were done that fixed this in WoaM and the custom resolution that game has.

Not sure if the kathy rain 'refrigerator text' in a puzzle near the end of the game is fixed too, but it might be (it depends on line height and size manipulation iirc).

comment:3 by i30817, 20 months ago

BTW, the plugin that affects this (agsspritefont) was used in the new game 'The Excavation of Hob's Barrow', in the 'clifftop' configuration, and was distributed with a new name.

Which is a bit problematic in terms of hardcoding because upstream is undecisive if it will allow a 'alternate name'.

https://github.com/adventuregamestudio/ags/issues/1796

Currently, this crashes scummvm when i try to load it, with or without the plugin asked for the information to build in that linked bug (it runs on upstream with the built .so). Maybe because scummvm won't load the so anyway? Or maybe because the plugin code is outdated anyway, and the ABI changed.

Anyway, it needs a update to run that game, and hopefully upstream hardcodes it, like kathy rain and woam. Otherwise, build the plugin for your OS and place it on the game dir (assuming the scummvm port will load those anyway). This is slightly less portable, which is why i'd prefer the hardcoding.

comment:4 by criezy, 20 months ago

BTW, the plugin that affects this (agsspritefont) was used in the new game 'The Excavation of Hob's Barrow', in the 'clifftop' configuration

I have now changed the detection for The Excavation of Hob's Barrow to use the Clifftop Games variant of the plugin.

and was distributed with a new name

If you mean "agsplugin.spritefont", this is not a new name. In ScummVM we added support for that name two years ago in https://github.com/scummvm/scummvm/commit/f556ba3f. The commit message indicates it fixes startup for Kathy Rain, so I am guessing some versions of Kathy Rain use that name (the ones I have all use "AGSSpriteFont" though).

comment:5 by i30817, 20 months ago

Interestingly upstream rejected that one as a hack. I should close my bug report about this.

comment:6 by criezy, 17 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

As mentioned by i30817 in comment:2, this bug was fixed upstream some months ago. I have now merged that fix in ScummVM and checked that it indeed works correctly now.

comment:7 by Thunderforge, 17 months ago

Confirmed to be fixed in daily build 2022-12-16 (macosx-x86_64-master-da8d47e7).

Thank you for fixing this!

Note: See TracTickets for help on using tickets.