Opened 4 weeks ago

Closed 3 weeks ago

#12948 closed defect (fixed)

AGS: Segfault when picking up at police report (Kathy Rain)

Reported by: Thunderforge Owned by: criezy
Priority: high Component: Engine: AGS
Version: Keywords: kathyrain
Cc: Game:

Description

In Kathy Rain (kathyrain), when picking up the police report from the shelf, a segfault occurs.

Because this is a necessary action in the game, the game cannot be completed (and this is only 15 minutes into the game…).

Reproduction steps

  1. Load the attacked save game
  2. Click on the bookshelf behind the desk and select "Search Files"
  3. Kathy will say "Okay, let's have a look…" and then ScummVM will crash with a segfault

Log

Process:               scummvm [40690]
Path:                  /Applications/ScummVM.app/Contents/MacOS/scummvm
Identifier:            org.scummvm.scummvm
Version:               2.4.0git (2.4.0git)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           scummvm [40690]
User ID:               502

Date/Time:             2021-09-19 18:12:22.420 -0500
OS Version:            macOS 11.5.2 (20G95)
Report Version:        12
Anonymous UUID:        0AA5D204-3785-7750-75EA-380129269336

Sleep/Wake UUID:       33B30518-0541-48C4-825C-19DF421D63AB

Time Awake Since Boot: 300000 seconds
Time Since Wake:       7900 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
Assertion failed: (_fonts[_size]), function getFont, file /data/src/master/engines/ags/lib/alfont/alfont.cpp, line 41.
 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff2042f92e __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff2045e5bd pthread_kill + 263
2   libsystem_c.dylib             	0x00007fff203b3406 abort + 125
3   libsystem_c.dylib             	0x00007fff203b27d8 __assert_rtn + 314
4   org.scummvm.scummvm           	0x000000010af78530 0x10abcc000 + 3851568
5   org.scummvm.scummvm           	0x000000010af786e7 0x10abcc000 + 3852007
6   org.scummvm.scummvm           	0x000000010afa7125 0x10abcc000 + 4043045
7   org.scummvm.scummvm           	0x000000010afa5482 0x10abcc000 + 4035714
8   org.scummvm.scummvm           	0x000000010b0141bc 0x10abcc000 + 4489660
9   org.scummvm.scummvm           	0x000000010afa5cac 0x10abcc000 + 4037804
10  org.scummvm.scummvm           	0x000000010b0b98c5 0x10abcc000 + 5167301
11  org.scummvm.scummvm           	0x000000010b0f73be 0x10abcc000 + 5419966
12  org.scummvm.scummvm           	0x000000010afc49eb 0x10abcc000 + 4164075
13  org.scummvm.scummvm           	0x000000010afc8380 0x10abcc000 + 4178816
14  org.scummvm.scummvm           	0x000000010b0202ea 0x10abcc000 + 4539114
15  org.scummvm.scummvm           	0x000000010b021137 0x10abcc000 + 4542775
16  org.scummvm.scummvm           	0x000000010b01964f 0x10abcc000 + 4511311
17  org.scummvm.scummvm           	0x000000010b01939e 0x10abcc000 + 4510622
18  org.scummvm.scummvm           	0x000000010b0ed628 0x10abcc000 + 5379624
19  org.scummvm.scummvm           	0x000000010b0ab102 0x10abcc000 + 5107970
20  org.scummvm.scummvm           	0x000000010b02d9f7 0x10abcc000 + 4594167
21  org.scummvm.scummvm           	0x000000010b02e505 0x10abcc000 + 4596997
22  org.scummvm.scummvm           	0x000000010b02e5c3 0x10abcc000 + 4597187
23  org.scummvm.scummvm           	0x000000010b108238 0x10abcc000 + 5489208
24  org.scummvm.scummvm           	0x000000010b1079ee 0x10abcc000 + 5487086
25  org.scummvm.scummvm           	0x000000010b10899f 0x10abcc000 + 5491103
26  org.scummvm.scummvm           	0x000000010b1088f3 0x10abcc000 + 5490931
27  org.scummvm.scummvm           	0x000000010b109e52 0x10abcc000 + 5496402
28  org.scummvm.scummvm           	0x000000010b10153a 0x10abcc000 + 5461306
29  org.scummvm.scummvm           	0x000000010af5c006 0x10abcc000 + 3735558
30  org.scummvm.scummvm           	0x000000010abfc261 0x10abcc000 + 197217
31  org.scummvm.scummvm           	0x000000010abfa23f 0x10abcc000 + 188991
32  org.scummvm.scummvm           	0x000000010abf6290 0x10abcc000 + 172688
33  libdyld.dylib                 	0x00007fff20479f3d start + 1

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x000000011362be00  rcx: 0x00007ffee5030d18  rdx: 0x0000000000000000
  rdi: 0x0000000000000103  rsi: 0x0000000000000006  rbp: 0x00007ffee5030d40  rsp: 0x00007ffee5030d18
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000246
  r12: 0x0000000000000103  r13: 0x000000011598f000  r14: 0x0000000000000006  r15: 0x0000000000000016
  rip: 0x00007fff2042f92e  rfl: 0x0000000000000246  cr2: 0x000000011598f000

Version

  • Kathy Rain 1.0.4 Steam
  • ScummVM Daily 2021-09-21 macOS x64

Attachments (1)

kathyrain.004 (770.5 KB ) - added by Thunderforge 4 weeks ago.
Savegame before the segfault

Download all attachments as: .zip

Change History (2)

by Thunderforge, 4 weeks ago

Attachment: kathyrain.004 added

Savegame before the segfault

comment:1 by criezy, 3 weeks ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

This bug is now fixed. The issues was that the game was failing to load the font for the police report due to a size mismatch between the font (which is a non-scalable Windows font) and the requested size.

But I created bug #12964 as the font being used in both ScummVM and the standalone AGS seems to be a different one from the one used by the modified AGS bundled with the game (which maybe explains the size mismatch).

Note: See TracTickets for help on using tickets.