Opened 4 months ago

Closed 3 weeks ago

#12934 closed defect (fixed)

BURIED: Hotkey for pausing the game doesn't work

Reported by: Thunderforge Owned by: bluegr
Priority: normal Component: Engine: Buried
Version: Keywords: buried-win
Cc: Game: Journeyman Project 2: Buried in Time

Description

According to the manual, the game can be paused with Control + P on Windows and Command + P on Macintosh. (This is the same functionality as pausing the game from the command in "Biochip - Interface").

Expected

  • On Windows, pressing Control + P will pause the game
  • On macOS, pressing Command + P will pause the game

(Undefined behavior for other platforms, but presumably the Windows one since most non-Mac platforms lack a Command key).

Actual

Pressing the pause hotkey on any platform does nothing.

Versions

  • ScummVM 2.3.0pre 2021-09-15
    • macOS 11.5.2
    • Windows 10 Pro 20H2
  • The Journeyman Project 2: Buried in Time
    • v1.00 24BPP/Windows/English (CD release)
    • v1.1 24BPP/Windows/English (GOG release)

Change History (2)

comment:1 by jamie-marchant, 3 weeks ago

I can confirm this is an issue.

comment:2 by bluegr, 3 weeks ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.