Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#12921 closed defect (invalid)

AGS: Puzzle in Apprentice can't be solved

Reported by: tag2015 Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

In the well-known AGS game "Apprentice", there is a timed puzzle that requires to hide and then quickly climb a staircase while a character looks the other way.
See this video walkthrough:
https://youtu.be/I8symMZzKW0?t=24

When played using scummvm, Pip's walking speed is much slower and he never manages to get upstars before the wizard goes back to his room.
Steps to reproduce

  1. Use master's door
  2. Immediately walk to the "dark corner"
  3. As soon as he finishes his line <<where are you Pib?>> click on the stairs ("walk to upstairs")
  4. The game should now move to the upstairs room; instead, the magician says something like "i hate it when he does that" and goes back to his room closing the door.

This occurs identically in the standard and the deluxe version.

Game is freeware and can be downloaded from the official website
http://www.herculeaneffort.com/index.php?page=apprentice1

ScummVM 2.4.0git251-g879ebd4d6c (Sep 11 2021 05:18:11)

Attachments (1)

apprentice-1.001 (405.6 KB ) - added by tag2015 9 months ago.

Download all attachments as: .zip

Change History (3)

by tag2015, 9 months ago

Attachment: apprentice-1.001 added

comment:1 by dreammaster, 8 months ago

Owner: set to dreammaster
Resolution: invalid
Status: newclosed

Thanks for the report. I confirmed that it worked properly with the release build. It's just the slower debug-enabled nightly builds that has the problem. Since there's already a pending story to eventually improve performance on nightly builds, I'm going to close this story.

comment:2 by criezy, 8 months ago

I was wondering about that bug, because even with a release build it is not working properly for me and I can reproduce the bug as described here (after reaching the top of the stairs, but before the room changes, I see the magician go back to his room). Maybe it is because my laptop is not powerful enough, but the game peaks at less than 50% CPU so I would expect it has some CPU cycles to spare.

Note: See TracTickets for help on using tickets.