Opened 3 months ago

Closed 3 months ago

#12903 closed defect (fixed)

SCUMM: FT: Sometimes skipping videos occur

Reported by: ctoroman Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Full Throttle

Description

I built my own scummvm using mingw32

Used engines scumm_7_8, gob, kyra, mohawk, myst3
Tried different SDLs, 1-st and 2-nd versions
Tried different GCC compilers, 7.2 - 9.3

In all cases, this problem appears periodically.

Attachments (1)

bug.avi (666.3 KB ) - added by ctoroman 3 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 by ctoroman, 3 months ago

I built scummvm v2.2 for testing. There are no problems with this version.

comment:2 by athrxx, 3 months ago

Thanks for your report.

Is that a specific scene where this happens? Or does it skip even the intro?

Does ist skip over the video completely? Or does it abort sometime during the playback?

comment:3 by ctoroman, 3 months ago

The intro works well. The video is interrupted sometimes during the game. I'll make a snippet where this happens

comment:4 by ctoroman, 3 months ago

The scene where Ben falls off a motorcycle, a reporter runs up to him. At this point, the video may be interrupted and Ben will be in Maureen's house.
And it must be that the reporter takes a picture of him, says that he can offer him help, and then only Ben is at Maureen's.

by ctoroman, 3 months ago

Attachment: bug.avi added

comment:5 by ctoroman, 3 months ago

bug at the 5th second

comment:6 by athrxx, 3 months ago

Okay, that's weird. I thought maybe you're just missing a file, but this is an abort right in the middle of the playback of dazed.san .

I currently cannot reproduce this with FT English.

What language version do you use?

Does the bug always occur at the exact same position?

comment:7 by ctoroman, 3 months ago

No not always. Sometimes the video ends a few seconds later. Sometimes it does not break off at all. Sometimes it breaks off in other places. For example, when a plane crashes into an abyss or when "Rats" blow up a trailer.

I am using the Russian version.

When I play using scummvm 2.2, everything works fine.

Previously, everything worked in scummvm version 2.3. It started about half a year ago.

comment:8 by AndywinXp, 3 months ago

Hi there, this sounds too familiar to the point that it seems the same bug I've encountered myself some days ago on COMI: do you have autosaving activated? When an autosave is triggered during a .SAN (SMUSH) cutscene, the latter is stopped and skipped entirely.

I had a fix in place for COMI but if this is the case for FT, we should have a similar fix for FT and DIG.

Last edited 3 months ago by AndywinXp (previous) (diff)

comment:9 by athrxx, 3 months ago

Thanks for that clue, that really saves me a lot of time :-)

Yes, with autosave on it will cut off the smush sequences in FT. I've just tried with a short autosave interval...

comment:10 by athrxx, 3 months ago

@ctoroman: I've made a fix. Please test whether the issue is gone. In that case I will also push it into the release branch.

comment:11 by ctoroman, 3 months ago

Many thanks! Everything is ok

comment:12 by athrxx, 3 months ago

Thanks for confirming!

comment:13 by athrxx, 3 months ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.