Opened 2 weeks ago

Closed 11 days ago

#12881 closed defect (fixed)

BURIED: No Research points awarded for examining Biochip - Files

Reported by: Thunderforge Owned by: eriktorbjorn
Priority: normal Component: Engine: Buried
Version: Keywords: buried-win
Cc: Game: Journeyman Project 2: Buried in Time

Description (last modified by Thunderforge)

According to three different walkthroughs (here, here, and here), you are supposed to be able to get 3 Research points for opening up "Biochip - Files" and examining each of the following

  • The information on the Jumpsuit
  • Agent 3's dossier
  • Agent 3's profile

However, none of these are actually awarded.

Because of this bug, a perfect score of 15000 is impossible to achieve.

Reproduction steps

  1. Load the attached save game, which is a fresh game with 0 points on it, with Gage positioned right next to a pit in the Da Vinci era
  2. In your inventory, scroll to "Biochip - Files"
  3. Click the icon to select the biochip
  4. In the Biochip Display, click "Access"
  5. Click "Jumpsuit Overview"
  6. Click the down arrow three times (1 Research point is supposed to be awarded)
  7. Click "Return"
  8. Click "Agent Dossiers"
  9. Click "Research Unit"
  10. Click "Agent 3 - Visard, Michelle" (1 Research point is supposed to be awarded)
  11. Click "Profile" (1 Research point is supposed to be awarded)
  12. Click "Return"
  13. Click "Missions" (1 Research point is supposed to be awarded)
  14. Click "Return"
  15. In the Biochip Display, click the "Exit" button
  16. Walk forward one step, which will result in you falling to your death and the death screen being brought up, which shows among other things the "Research Bonus"

Expected: "Research Bonus: "3/15 x 100 = 300"
Actual: "Research Bonus: "0/15 x 100 = 0"

For good measure, I also exhaustively examined every single page in Biochip - Files, but still no points are awarded.

Versions

  • ScummVM 2.3.0pre 2021-08-31
  • Windows 10 Pro 20H2
  • The Journeyman Project 2: Buried in Time v1.00 24BPP/Windows/English

Attachments (1)

buried-New Game Da Vinci.sav (1.1 KB ) - added by Thunderforge 2 weeks ago.

Download all attachments as: .zip

Change History (10)

by Thunderforge, 2 weeks ago

comment:1 by Thunderforge, 2 weeks ago

Description: modified (diff)

comment:2 by Thunderforge, 2 weeks ago

Description: modified (diff)

comment:3 by Thunderforge, 2 weeks ago

Description: modified (diff)
Summary: BURIED: No Research points awarded for examining FilesBURIED: No Research points awarded for examining Biochip - Files

comment:4 by Thunderforge, 2 weeks ago

Description: modified (diff)

comment:5 by eriktorbjorn, 2 weeks ago

It looks to me like the bugs are in FilesBioChipViewWindow::onLButtonUp().

I don't have the time to submit a pull request just yet, but I have a work-in-progress branch at https://github.com/eriktorbjorn/scummvm/commits/buried-fix-12881

(Note that it seems to award points for just looking at the Agent 3 page, not for looking at the missions page. I don't know if that's correct behavior.)

comment:6 by Thunderforge, 2 weeks ago

Description: modified (diff)

(Note that it seems to award points for just looking at the Agent 3 page, not for looking at the missions page. I don't know if that's correct behavior.)

Rereading the three walkthroughs, I think you are correct.

[Three research points are awarded for reading various files: 1) Jumpsuit, 2) Visard Dossier, 3) Visard Profile. 0/0/0/3]

2) And read Visard (aka Agent 3's) dossier in the Files Biochip.

Select your Files biochip and read the files on the Jumpsuit (100) and the all the TSA Agent Dossiers (100) and Profiles (100).

They all say "Dossier", not "Mission page", so that was my mistake. (The last one is incorrect, you don't have to look at all of them). I've updated the ticket description to reflect this.

FYI, there was an official strategy guide for the game that I believe was created by Presto, but I don't own it. If there's ever a debate about what is "correct" behavior for the game, that might be a good resource.

comment:7 by eriktorbjorn, 2 weeks ago

I've cleaned up one of my commit messages (sorry about the force push) and submitted a pull request: https://github.com/scummvm/scummvm/pull/3337

comment:8 by Thunderforge, 2 weeks ago

Keywords: buried-win added; buried removed

comment:9 by sev-, 11 days ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

The pull request now has been merged. The issue is fixed.

Note: See TracTickets for help on using tickets.