Opened 7 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#12877 closed defect (fixed)

BURIED: Volume controls other than "Mute All" do not work

Reported by: Thunderforge Owned by: Thunderforge
Priority: high Component: Engine: Buried
Version: Keywords: buried-win
Cc: Game: Journeyman Project 2: Buried in Time

Description

The only volume control that affects Buried in Time is "Mute All". I expect that all the controls should work.

Reproduction Steps

  1. In ScummVM, go to Options… → Volume
  2. Check "Mute All"
  3. Click "Apply"
  4. Start Buried in Time.
  5. Expected Behavior: Music sound effects and speech will all be off
  6. Close Buried in Time
  7. In ScummVM, go to Options… → Volume
  8. Uncheck "Mute All"
  9. Set "Music volume", "SFX volume", and "Speech volume" to 0
  10. Click "Apply"
  11. Start Buried in Time.
  12. Unexpected Behavior: Music, sound effects, and speech are all at full volume
  13. Close Buried in Time
  14. In ScummVM, go to Options… → Volume
  15. Uncheck "Mute All"
  16. Set "Music volume", "SFX volume", and "Speech volume" to 256
  17. Click "Apply"
  18. Start Buried in Time.
  19. Unexpected Behavior: Music, sound effects, and speech are all at full volume, and just as loud as they were when set to 0

I ran into this because I thought that the music was too loud and was drowning out the voices. I tried turning down the music, but it made no difference. I eventually found that none of the volume controls were responding, except for Mute All.

Versions

  • ScummVM Windows nightly 2021-08-31
  • The Journeyman Project 2: Buried in Time 1.00 24-bit

Change History (4)

comment:1 by Thunderforge, 7 weeks ago

Also found that setting Options… → Audio → Preferred Device to "No music" has no effect.

comment:2 by sev-, 7 weeks ago

Priority: normalhigh

This would be nice to have fixed before the release.

comment:3 by Thunderforge, 6 weeks ago

Keywords: buried-win added; buried removed

comment:4 by NMIError, 6 weeks ago

Owner: set to Thunderforge
Resolution: fixed
Status: newclosed

Volume control has been added.

Due to the nature of the sound code for this engine, the different volume controls do not represent the types of sound in the game exactly:

Ambient (music, environment sounds): music
AI voice: speech
Effects, interface, footsteps, movie audio: SFX

The movie audio is pre-mixed music, speech and SFX; only the overall volume can be controlled using the SFX volume control.

Last edited 6 weeks ago by NMIError (previous) (diff)
Note: See TracTickets for help on using tickets.