Opened 10 months ago

Closed 9 months ago

#12871 closed defect (duplicate)

AGS: Animation slow in Maniac Mansion Deluxe

Reported by: OzzieMonkey Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game: Maniac Mansion

Description (last modified by OzzieMonkey)

The game's animation is much slower than the original, particularly the walking animation. Doesn't seem to matter which version is running, nightly build or pre-release, the same issue persists. Nothing special needed to replicate, just start a new game and from the meteor falling onwards it's slow.

Running on Windows 10 Pro 19043.1165
GPU: AMD Radeon RX 5600XT
CPU: AMD Ryzen 5 2600

Change History (7)

comment:1 by OzzieMonkey, 10 months ago

Description: modified (diff)

comment:2 by criezy, 10 months ago

I cannot reproduce it. The games seems to run at the same speed as the original for me.

Since I don't have a Windows computer I am not able to run the original, so I used this Youtube video for reference: https://www.youtube.com/watch?v=HErt9fMRuOc

I am using my debug version of ScummVM (without optimisations) on a MacBook Air M1 and it uses about 32% of 1 CPU. So with the specs you have it is unlikely to be limited by the CPU (even with a ScummVM version that is not optimised). But can you check the CPU usage while playing the game to be sure?

I also timed the intro in this video and with the game running in ScummVM on my mac and I have exactly the same timing.

  • From the moment we start the game after selecting the three characters (Dave, Bernard, and Jeff) until they appear, the intro sequence takes 1 min and 16 seconds (from 0:16 to 1:32 in the youtube video).
  • Then it takes a further 42s (until 2:14 in the video) of talking until you the end of the intro.

And in the game itself walking seems to also be at the same speed as in the video (it takes less than 3s to walk the width of one screen).

Can you provide some numbers for you to get an idea of how much slower it is?

comment:3 by sev-, 10 months ago

Priority: highnormal

comment:4 by sev-, 10 months ago

Summary: Animation slow in Maniac Mansion DeluxeAGS: Animation slow in Maniac Mansion Deluxe

comment:5 by OzzieMonkey, 10 months ago

So I've worked out that editing the acsetup.cfg file effects the speed of the game, specifically
implementing the [override] upscale=1 setting. I realized that I was using this when I ran the game natively to make the text look better. Unfortunately this makes the animation slow down. The game text does look dramatically improved with this setting but the animation bug makes it useless atm.

comment:6 by criezy, 10 months ago

Indeed, adding this upscale=1 in the acsetup.cfg file does slow down the animation (and also makes the text look better).
The first part of the intro sequence takes about 1:36 instead of 1:16 for me, and walking across the screen takes a bit more than 5s (so about twice as much as without the option).

And while using more CPU, this is still far from using 100% of a CPU though, so it does not look like the slowdown is caused by that.

Is it possible that the original is also slower when using this option?

comment:7 by dreammaster, 9 months ago

Owner: set to dreammaster
Resolution: duplicate
Status: newclosed

Quite likely. Even though the release builds are faster than nightly debug builds, certainly any general performance improvement eventually done to make nightly builds faster will have a knock on effect to make the release builds faster when doing higher resolutions. Since we already have an open story for improving rendering performance of games, I'm going to close this as a duplicate.

Note: See TracTickets for help on using tickets.