Opened 16 years ago

Closed 16 years ago

Last modified 12 months ago

#1287 closed defect (duplicate)

ALL: SDL crash (regression)

Reported by: SF/logicdeluxe Owned by: eriktorbjorn
Priority: normal Component: Port: Win32
Keywords: Cc:
Game: Maniac Mansion

Description

Whenever I select a game in the launcher ScummVM exits
with an SDL crash. For instance:
c:\scummvm>scummvm.exe
Looking for maniac
Trying to start game 'Maniac Mansion'
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Running "scummvm maniac" has the same effect. Also the
contents/presents of the scummvm.ini doesn't matter. I
also tried "scummvm -d 9", and there is no debug output
at all.

I noticed this as I compiled the today's snapshot with
mingw (no complains during compiling). As I checked the
daily builds, it also happens there.
The problem appeared between ScummVM 0.5.4cvs (Oct 23
2003 19:09:21) and ScummVM 0.5.4cvs (Oct 27 2003 16:04:09)
I also tried downgrading to SDL 1.2.5 which didn't
solve the problem either.
I'm using German Win98SE.

Ticket imported from: #831140. Ticket imported from: bugs/1287.

Change History (6)

comment:1 by fingolfin, 16 years ago

Owner: set to eriktorbjorn

comment:2 by fingolfin, 16 years ago

Can't reproduce this with current CVS. But I saw that erik
commited some bug fix earlier for another bug, maybe that
covered it...

comment:3 by SF/logicdeluxe, 16 years ago

It seems that those fixes covered it. Today's snapshot works
again.

comment:4 by eriktorbjorn, 16 years ago

Resolution: duplicate
Status: newclosed

comment:5 by eriktorbjorn, 16 years ago

For reference, the original bug was #830772

Closing this as a duplicate, then.

comment:6 by digitall, 12 months ago

Component: --Unset--Port: Win32
Game: Maniac Mansion
Note: See TracTickets for help on using tickets.