#12869 closed defect (fixed)

AGS: 5daysastranger - saved game names retain first letter only

Reported by: Arjak89 Owned by: criezy
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

When saving in 5 Days a Stranger, only the first letter of the name is retained. This occurs with both manual and automatic saves.

ScummVM version: 2.3.0pre37-gb8d6afb0a2 (Win64)

Change History (4)

comment:1 by tag2015, 11 months ago

I have noticed this behavior on various AGS games (all of Yahtzee's releases and some others for example), but it is merely a cosmetic issue.
If you save using the AGS save screen and then load using ScummVM menu, you can see that the string is actually complete.
But using the AGS load screen (the "grey box") for some reason only the first character is shown.

in reply to:  1 comment:2 by antoniou79, 11 months ago

Replying to tag2015:

I have noticed this behavior on various AGS games (all of Yahtzee's releases and some others for example), but it is merely a cosmetic issue.
If you save using the AGS save screen and then load using ScummVM menu, you can see that the string is actually complete.
But using the AGS load screen (the "grey box") for some reason only the first character is shown.

I should add to this, that the ScummVM Load Game dialogue will show the full save name, only in List view. In the Grid View (the one with the screenshot panels), the description is completely missing (not even the first letter). At least this is the behavior I'm seeing testing on Windows 10 x64 with "7 Days a Sceptic". (Which also has the bug with only the first letter showing in the native Save and Load panels.

comment:3 by criezy, 11 months ago

The issue in the AGS load dialog was caused by a recent change to use U32 strings for savegame descriptions (with 4 bytes per characters). But the code in AGS had not been updated and was still treating it as a 8-bit string (1 byte per character). As the second byte of the string is null, it though the end of the string had been reached.
This is now fixed.

The issue with the ScummVM load dialog Grid view is a separate issue.

comment:4 by criezy, 11 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

The second issue is now fixed as well.

Note: See TracTickets for help on using tickets.