Opened 5 months ago

Closed 5 months ago

#12853 closed defect (invalid)

STARK: Black screen with artifacts when closing a ScummVM msgbox or GMM with OpenGL Game 3D renderer

Reported by: antoniou79 Owned by: aquadran
Priority: normal Component: Engine: Stark
Version: Keywords: The Longest Journey, black screen, flashing rectangles
Cc: Game: The Longest Journey

Description (last modified by antoniou79)

This is with a recent build from master, 2.3.0git, on Windows 10 (all updated installed).

ScummVM 2.3.0git (Aug 28 2021 16:10:13)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) TinyGL OpenGL (with shaders) GLEW

The game is run with "OpenGL" as Game 3D Renderer. The issue does not occur if the game is run with "OpenGL with shaders" as the renderer.

I've had saved the game three times, using the game's own native save game panel (not ScummVM GMM), and one of my saved games was using the autosave slot. I've left the game idle for a while and I am assuming at what was the autosave interval (5 minutes?) it prompted me with a dialogue to choose if I wanted to overwrite the game saved on the autosave slot. (image attached: scummvm-tlj-win-00000.jpg)

I chose the "overwrite" option, at which point the screen became black and there were some rectangle shapes on the screen that seemed to react (flashing) when moving the mouse. (image attached: scummvm-tlj-win-00001.jpg)

I could not recover the game from that point, nor bring up the GMM, so I had to Alt-F4 to exit the game.

After re-launching ScummVM, the overwritten slot (from ScummVM launcher "Load") looks glitched too (see attached image: scummvm-tlj-win-00002.png​). It also looks glitched in the in-game save game panel.

Edit: The issue will occur even if the player brings up the ScummVM GMM and then chooses Resume.

Side bug (now fixed): Saving via the game's native save game panel, you cannot enter a description for the save game; the game automatically sets one for you based on current chapter and timestamp. However, notice the ScummVM prompt for the autosave overwrite (the attached scummvm-tlj-win-00000.jpg). The game is described as "P" (maybe from "Prologue"?). This seems bugged. Edit: This side bug should be now fixed by https://github.com/scummvm/scummvm/commit/5f9b39e55bd86a69fe273b46e5b09e236be57826

Attachments (3)

scummvm-tlj-win-00001.png (8.3 KB ) - added by antoniou79 5 months ago.
scummvm-tlj-win-00000.jpg (150.0 KB ) - added by antoniou79 5 months ago.
scummvm-tlj-win-00002.png (103.6 KB ) - added by antoniou79 5 months ago.

Download all attachments as: .zip

Change History (11)

by antoniou79, 5 months ago

Attachment: scummvm-tlj-win-00001.png added

by antoniou79, 5 months ago

Attachment: scummvm-tlj-win-00000.jpg added

comment:1 by antoniou79, 5 months ago

Description: modified (diff)

comment:2 by antoniou79, 5 months ago

Description: modified (diff)

by antoniou79, 5 months ago

Attachment: scummvm-tlj-win-00002.png added

comment:3 by antoniou79, 5 months ago

Description: modified (diff)

comment:4 by antoniou79, 5 months ago

Additional info: Choosing the "Move" option from the same dialogue resulted in a messagebox informing me that it was impossible to perform that move action, and then I got the black screen with the rectangles again.

comment:5 by antoniou79, 5 months ago

Description: modified (diff)

comment:6 by antoniou79, 5 months ago

Description: modified (diff)

Added extra info in the original description for the ticket:

  1. The issue occurs when the game is run with "OpenGL" as Game 3D Renderer. The issue does not occur if the game is run with "OpenGL with shaders" as the renderer.
  1. The issue is more broad than I originally thought. It will occur even if the player brings up the ScummVM GMM and then chooses Resume.

comment:7 by antoniou79, 5 months ago

Summary: STARK: Black screen with flashing rectangles when choosing to overwrite an autosaveSTARK: Black screen with artifacts when closing a ScummVM msgbox or GMM with OpenGL Game 3D renderer

comment:8 by aquadran, 5 months ago

Owner: set to aquadran
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.