Opened 3 years ago

Closed 9 months ago

#12837 closed defect (worksforme)

DIRECTOR: Crash during Spaceship Warlock demo 1.1.1

Reported by: Thunderforge Owned by: Thunderforge
Priority: normal Component: Engine: Director
Version: Keywords: warlock-demo-mac
Cc: Game:

Description

While running Spaceship Warlock Demo 1.1.1 downloaded from the ScummVM demo page, after several minutes ScummVM crashes with this error:

[2021-08-23 19:36:45] WARNING: FSNode::createReadStream: 'rsrc' does not exist!
[2021-08-23 19:37:03] WARNING: FSNode::createReadStream: 'rsrc' does not exist!
[2021-08-23 19:37:27] WARNING: FSNode::createReadStream: 'rsrc' does not exist!
[2021-08-23 19:37:46] WARNING: openMainArchive(): Could not open 'Asteroids:TITLE'!
[2021-08-23 19:37:46] WARNING: nextMovie: No movie is loaded!
[2021-08-23 19:37:46] --- Log closed successfully.

Versions

  • ScummVM x64 2021-08-23 (g8812574dc8)
  • macOS 11.5.2

Change History (6)

comment:1 by eriktorbjorn, 3 years ago

When I run it, it complains about "ASTERODS:TITLE.MMM", not "Asteroids:TITLE.MMM", but maybe that's a transcription error?

Either way, there is a TITLE.MMM but it's in the root folder, not the asterods folder. If I copy it to asterods, the demo runs to what I assume is the end. It's pretty glitchy, though.

This is not an error in how the demo is packaged, though, because it's the exact same on my Spaceship Warlock CD, which includes both a demo and the full game. It would probably be useful if someone could run the demo with the original EXE and see if the title animation is played or skipped.

comment:2 by Thunderforge, 3 years ago

When I run it, it complains about "ASTERODS:TITLE.MMM", not "Asteroids:TITLE.MMM", but maybe that's a transcription error?

The log above, including Asteroids:TITLE was copied directly from the scummvm.log file. Assuming you're using demo 1.1.1, perhaps it's somehow a macOS thing?

comment:3 by eriktorbjorn, 3 years ago

The log above, including Asteroids:TITLE was copied directly from the scummvm.log file. Assuming you're using demo 1.1.1, perhaps it's somehow a macOS thing?

I couldn't find the version number, but I tried the warlock-win-demo.zip I found on the ScummVM web site, and which appears to be identical to the demo on my Windows CD.

(It's funny how that Windows demo clearly shows a Macintosh at one point, though!)

comment:4 by eriktorbjorn, 9 months ago

I can't reproduce this issue any more. Perhaps it has been fixed?

comment:5 by eriktorbjorn, 9 months ago

It's not flawless, though. After the demo restarted, it got stuck looping one smal bit of it over and over. But if that's reproducable, it's still a different issue of course.

comment:6 by Thunderforge, 9 months ago

Owner: set to Thunderforge
Resolution: worksforme
Status: newclosed

Yes, it appears the originally reported issue is fixed. My recollection is that game crashed when you arrived on the bridge (after the robot tells you to go there). That no longer happens.

There is a repeated loop later, but that's not the original issue, so I'm closing this.

Note: See TracTickets for help on using tickets.