Opened 5 months ago

Closed 5 months ago

#12836 closed defect (worksforme)

AGS: Segfault when starting up Dead Dimension

Reported by: Thunderforge Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords: deaddimension
Cc: Game:

Description

A segfault appears immediately upon launching Dead Dimension

Logs

Process:               scummvm [4356]
Path:                  /Applications/ScummVM.app/Contents/MacOS/scummvm
Identifier:            org.scummvm.scummvm
Version:               2.3.0git (2.3.0git)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           scummvm [4356]
User ID:               502

Date/Time:             2021-08-23 17:58:20.516 -0500
OS Version:            macOS 11.5.2 (20G95)
Report Version:        12
Anonymous UUID:        0AA5D204-3785-7750-75EA-380129269336

Sleep/Wake UUID:       F77C5D79-DBA4-4BC4-A264-1C812C8C9594

Time Awake Since Boot: 10000 seconds
Time Since Wake:       3200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       EXC_I386_GPFLT
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [4356]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   org.scummvm.scummvm           	0x0000000106134a15 0x105bf1000 + 5519893
1   org.scummvm.scummvm           	0x0000000105f8559f 0x105bf1000 + 3753375
2   org.scummvm.scummvm           	0x0000000105c26662 0x105bf1000 + 218722
3   org.scummvm.scummvm           	0x0000000105c2459f 0x105bf1000 + 210335
4   org.scummvm.scummvm           	0x0000000105c20950 0x105bf1000 + 194896
5   libdyld.dylib                 	0x00007fff203f0f3d start + 1

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000600003371d00  rbx: 0x0000000000000000  rcx: 0x00007fb67a488400  rdx: 0x0000000000000000
  rdi: 0x0000600003371d00  rsi: 0x0000bb4982a51d00  rbp: 0x00007ffeea00ce50  rsp: 0x00007ffeea00cc60
   r8: 0x0000bb4982701b00   r9: 0x0000000000000020  r10: 0x00000000000007fb  r11: 0x0000000000000200
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x0000000106134a15  rfl: 0x0000000000010202  cr2: 0xffffffa08368f0c4
  
Logical CPU:     0
Error Code:      0x00000000
Trap Number:     13

Thread 0 instruction stream:
  8b 00 48 8b b8 a8 0c 00-00 b8 28 00 00 00 48 89  ..H.......(...H.
  bd 20 fe ff ff 48 89 c7-e8 54 bb 9a 03 48 89 c7  . ...H...T...H..
  48 89 85 18 fe ff ff e8-4f f9 e8 ff 48 8b bd 20  H.......O...H.. 
  fe ff ff 48 8b b5 18 fe-ff ff e8 f2 74 99 03 e8  ...H........t...
  f7 fd ff ff e8 62 fe ff-ff 48 8d 05 8b 14 6c 04  .....b...H....l.
  48 8b 00 48 8b 80 b0 13-00 00 48 8b 30 48 89 c7  H..H......H.0H..
 [ff]96 a0 01 00 00 48 8d-05 6e 14 6c 04 48 8b 75  ......H..n.l.H.u	<==
  f0 48 8b 38 48 89 b7 80-26 00 00 8b 4d fc 48 8b  .H.8H...&...M.H.
  00 89 88 88 26 00 00 48-81 c4 f0 01 00 00 5d c3  ....&..H......].
  66 2e 0f 1f 84 00 00 00-00 00 90 55 48 89 e5 48  f..........UH..H
  83 ec 40 48 89 7d f8 48-89 75 f0 48 8b 45 f8 48  ..@H.}.H.u.H.E.H
  8b 4d f0 48 8b 11 48 89-10 48 8b 49 08 48 89 48  .M.H..H..H.I.H.H
  
Thread 0 last branch register state not available.

Versions

  • ScummVM x64 2021-08-23 (g8812574dc8)
  • macOS 11.5.2

Change History (5)

comment:1 by Thunderforge, 5 months ago

Summary: [AGS] Segfault when starting up Dead DimensionAGS: Segfault when starting up Dead Dimension

comment:2 by Thunderforge, 5 months ago

Component: --Unset--Engine: AGS

comment:3 by dreammaster, 5 months ago

Tried to replicate on my Windows build, both with a win32 and x64 build, but it worked in both. The only thing that comes to mind is that we've got a couple of pending bugs for AGS not working on foreign systems like Symbion and AmigaOS4. Is Dead Dimension the only game you tried, or do other games crash as well?

In either case, there's not much I can do further, unfortunately, since I can't replicate any problem. Maybe someone else with a Mac that does their own builds might be able to likewise try and see if they can replicate the problem, and if so, investigate the problem.

comment:4 by Thunderforge, 5 months ago

I can't reproduce the problem on the current build, so I guess something fixed it, or it was a fluke error.

comment:5 by Thunderforge, 5 months ago

Owner: set to dreammaster
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.