Opened 16 years ago

Closed 16 years ago

#1283 closed defect (fixed)

MANIAC: Dave walks odd in demo mode

Reported by: Kirben Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Latest ScummVM cvs version.
English version of V1 Maniac Mansion
Compiled under mingw with GCC 3.2.3 and running under
Windows XP.

When running demo mode of V1 Maniac Mansion, Dave
walks through stairs, then later back down stairs and
back up the stairs before entering the Mansion. In demo
mode of original game, Dave doesn't walk through the
stairs and just enters Mansion, he doesn't walk down
stairs again.

Ticket imported from: #830106. Ticket imported from: bugs/1283.

Change History (7)

comment:1 by fingolfin, 16 years ago

Summary: V1MANIAC: Dave walks odd in demo modeMANIAC: Dave walks odd in demo mode

comment:2 by Kirben, 16 years ago

This problem is caused by fingolfin's changes in
scumm/actor.cpp revision 1.179.
fingolfin, could you have a look at this issue ?

comment:3 by Kirben, 16 years ago

Owner: set to fingolfin

comment:4 by fingolfin, 16 years ago

Looking at the actual change you point at, Kirben: <http://
cvs.sourceforge.net/viewcvs.py/scummvm/scummvm/scumm/
actor.cpp?r1=1.178&r2=1.179>

Given the choice between breaking Maniac demo and Indy3, I don't
hesitate a split second... :-)

However, the odd thing is: bug #813136 has noting to do at all
with the walk code, in fact it was closed as invalid. Hrm, I don't
get it. I can undo that change, but I am not sure what this might
cause...

comment:5 by fingolfin, 16 years ago

Ah the comment was wrong, the regression in question was in bug
#809547.
I've put an experimental "fix" into CVS but I am not too happy
with this.

comment:6 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:7 by Kirben, 16 years ago

The fix works fine, so closing.
I played through v1 maniac/zak before that code change in
scumm/actor.cpp revision 1.179 was made and didn't notice
any similar issues. So hopefully shouldn't cause any problems.

Note: See TracTickets for help on using tickets.