Opened 10 months ago

Closed 6 weeks ago

#12817 closed defect (fixed)

SCI: No Title screen music in Mixed-up Mother Goose Deluxe

Reported by: RogerW123 Owned by: sluicebox
Priority: normal Component: Audio
Version: Keywords: No Music
Cc: Game: Mixed-Up Mother Goose Deluxe

Description

Trying Mixed-up Mother Goose Deluxe with ScummVM 2.2.0 and the 2.3.0 development build for August 15th. The game should play music on the title screen. Music does play on the Windows 64bit builds, but does NOT work in the OSX and Android builds.

Change History (6)

comment:1 by sluicebox, 10 months ago

I can confirm that no music plays in this game on Mac when building from latest source on the command line. But, music does play when building from latest source with Xcode. The 2.2.0 release also doesn't play music on Mac.

When there is no music, this is logged:

WARNING: SCUMMVM_MIDI environment variable not set, using /dev/sequencer!
WARNING: Cannot open rawmidi device /dev/sequencer - using /dev/null (no music will be heard)!

I set a breakpoint on the MidiDriver_SEQ constructor that produces this warning in Xcode, but the constructor is never called.

If I had to make a list of things I'm ignorant about, Macs and MIDI would be right at the top, so I hope that helps someone knowledgable. Happy to test things though.

The thing about this SCI game is that it only has a General MIDI version of its music. At least, that's the impression we're under according to GameFeatures::generalMidiOnly().

My Xcode setup is the standard one from following instructions on the wiki. My configure parameters are just to disable all engines except SCI,SCI32. All ScummVM audio settings are default.

comment:2 by sluicebox, 10 months ago

On Mac you can workaround this by setting Audio \ Preferred device to Apple DLS Software Synthesizer. Note that you have to do this on the Audio tab, if you do this on the MIDI tab it doesn't work. (I don't know why.)

I now see that the difference between the Xcode build and command line builds is that create_project doesn't set USE_SEQ_MIDI and MidiDriver_SEQ doesn't get used. At least for me, and you, MidiDriver_SEQ doesn't work by default. Is that on purpose? The more I look at this the more questions I have, like why does the Engine \ MIDI tab not populate the GM Device dropdown? (This is why I try to stay away from sound stuff!)

comment:3 by RogerW123, 9 months ago

That does indeed fix the issue Thanks.

comment:4 by antoniou79, 9 months ago

I cannot reproduce this issue on Android (Redmi Note 9 device) testing with recent developer (local) build (2.4.0git from Sep 6 2021).
This is the music that you get upon launching the game, is it not? I do hear music playing there.

comment:5 by sev-, 8 months ago

Summary: No Title screen music in Mixed-up Mother Goose DeluxeSCI: No Title screen music in Mixed-up Mother Goose Deluxe

comment:6 by sluicebox, 6 weeks ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in Mac builds: https://github.com/scummvm/scummvm/commit/1aabe9087e815efa56c9692c5b856b9e199528d6

SEQ MIDI is no longer an option in Mac builds and will no longer be the default device. Mixed-Up Mother Goose Deluxe will now play music on a default Mac config.

SEQ MIDI isn't on Android builds so that's not what was affecting that. Maybe the default device didn't work on that particular Android setup? We didn't get any more details on the particular Android setup so I don't think there's anything more to be done about that on this ticket.

On the PR, bonki said this could be improved on the SCI side too, so perhaps there is more to come. https://github.com/scummvm/scummvm/pull/3871

As always, feel free to re-open this ticket if necessary.

Note: See TracTickets for help on using tickets.