Opened 3 years ago

Closed 18 months ago

#12802 closed defect (fixed)

AGS: AMIGA: Black Screen/Window on start of nearly all games

Reported by: raziel- Owned by: dwatteau
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

ScummVM 2.3.0git (Aug 14 2021 12:01:56)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL

I get a black screen/window and unresponsive cummVM (only reboot possible) on nearly all games that run in the AGS engine.
I have actually found only one game that will start (Space Quest IV.5), all the other game i tested are stuck at a black screen.

Not sure if it's an endian issue or something else, maybe someone with a PPC BE machine other than mine could give it a test?

AmigaOS4 - PPC - SDL/OGLES2 - BE
gcc (adtools build 11.1.0) 11.1.0

Change History (10)

comment:1 by raziel-, 3 years ago

See also #12806

All the other games i tried never reach (or lock up before or while)

Opened game data file: xxx.xxx

comment:2 by sev-, 3 years ago

Summary: AGS: Black Screen/Window on start of nearly all gamesAGS: AMIGA: Black Screen/Window on start of nearly all games

comment:3 by raziel-, 3 years ago

This i get with one of the few games that formerly ran.
Any ideas?

I started the game with "SDL-Surface" in launcher, Game mode "OpenGL" and fullscreen

User picked target 'sq45' (engine ID 'ags', game ID 'sq45')...

Looking for a plugin supporting this target... Adventure Game Studio

WARNING: TODO: SetCurrentDirectory: Games:GamesVM/AGS/Space Quest/The Voyage Home/!
Initializing backend libs
Initializing game data
Opened game data file: ac2game.dta
Game data version: 32
Compiled with: 2.72
Startup directory: ./
Data directory: ./
Setting up game configuration
Voice pack found and initialized.
music.vox found and initialized.
Initializing TTF renderer
Initializing mouse: number of buttons reported is 3
Install timer
Initialize legacy path finder library
Game title: 'Space Quest 4.5'
Game GUI version: 115
WARNING: font 'agsfnt2.wfn' has mistakes in data format, some characters may be displayed incorrectly
WARNING: font 'agsfnt3.wfn' has mistakes in data format, some characters may be displayed incorrectly
WARNING: font 'agsfnt4.wfn' has mistakes in data format, some characters may be displayed incorrectly
WARNING: font 'agsfnt5.wfn' has mistakes in data format, some characters may be displayed incorrectly
Checking for disk space
Game native resolution: 640 x 480 (16 bit) letterbox-by-design
Graphic settings: driver: OGL, windowed: yes, screen def: scaling, screen size: 0 x 0, match device ratio: ignore, game scale: max_round
Requested graphics driver 'OGL' not found, will try existing drivers instead

comment:4 by dwatteau, 22 months ago

I can't reproduce this on either big-endian PS3 or big-endian PowerBook G4 running Linux or OS X.

Might be worth it to test a newer snapshot?

comment:5 by raziel-, 22 months ago

I'll try when I get back home.

Did you try anything else than OpenGL with shaders?

Thank you for checking

comment:6 by raziel-, 22 months ago

This has been fixed for at least SQ 4.5.

I still get a black screen for SQ Decision of the Elders (where it just sits there filling up my RAM slowly and nothing else happening)

I also can't really test other games since i encounter an immediate crash when trying to "Add Game" (with detection being a plugin) :-(

Probably still needs to be set to Pending?

comment:7 by dwatteau, 19 months ago

Hi raziel-! Does the SQ Decision of the Elders game still gives you a black screen on an up-to-date development build?

PR https://github.com/scummvm/scummvm/pull/4312 has been merged, and it should fix some AGS games on big-endian systems. The symptoms were similar to your "filling up my RAM slowly" description, so maybe this PR fixed this bug.

comment:8 by raziel-, 19 months ago

Will test asap and report back

Thank you

comment:9 by raziel-, 18 months ago

@dwatteau

Fixed.
Reported game now starts everytime and some more do too after a quick test

Thank you very much

Last edited 18 months ago by raziel- (previous) (diff)

comment:10 by dwatteau, 18 months ago

Owner: set to dwatteau
Resolution: fixed
Status: newclosed

@raziel-: Cool, thanks for your test!

Well, we still have some issues on big-endian AGS, but things are improving :) This particular fix will also be part of the 2.6.1 release.

Note: See TracTickets for help on using tickets.