Opened 16 years ago

Closed 12 years ago

#1280 closed defect (fixed)

SIMON1DOS/TALKIE: Chest disappears at Swampling\'s

Reported by: SF/logicdeluxe Owned by: Kirben
Priority: low Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

ScummVM 0.5.4cvs (Oct 23 2003 19:09:21) running on Windows.
Playing the German DOS talkie version.
At swampling the box disappears while the door is open
and reappears when the door is closed again.
To reproduce this, load the savegame and enter
swamplings home!

Ticket imported from: #828860. Ticket imported from: bugs/1280.

Attachments (1)

simon1.003 (3.0 KB) - added by SF/logicdeluxe 16 years ago.
at swampling, German version

Download all attachments as: .zip

Change History (14)

Changed 16 years ago by SF/logicdeluxe

Attachment: simon1.003 added

at swampling, German version

comment:1 Changed 16 years ago by Kirben

Issue was reported recently on forum of German's Simon the
Sorcerer fan site too, been meaning to add bug report for it.
Unfortunately this is another problem which only effects the
DOS versions, it doesn't occur in simon1win.

comment:2 Changed 16 years ago by Kirben

Summary: Simon1talkie: box disappears at swamplingSIMON1DOS/TALKIE: Box disappears at Swampling's

comment:3 Changed 16 years ago by Kirben

Priority: normallow

comment:4 Changed 16 years ago by Kirben

Summary: SIMON1DOS/TALKIE: Box disappears at Swampling'sSIMON1DOS/TALKIE: Chest disappears at Swampling's

comment:5 Changed 16 years ago by Kirben

This seems to be due to a conflict between two sprite.
When the candle light sprite near door is activated (When
Simon moves close) the chest disappears.
When the candle light sprite near door is deactivated (When
Simon moves away) the chest is shown again.
It is clear to see when background images are disabled via 'i'
key.

In simon1win only the the jar top disappears (Replaced by
background image of jar top) when the candle light sprite is
actived.
So the problem is two sprites are been deactived together in
simon1dos/talkie when only one sprite should be.

comment:6 Changed 15 years ago by SF/storm_rider

Also occurs in PocketPC version.
Helped me find the trap door though :)

comment:7 Changed 14 years ago by fingolfin

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2Space Quest 2

comment:8 Changed 14 years ago by fingolfin

So is this a scripting bug (a difference between Simon DOS
and WIN scripts) ? If so, could a workaround be added?

Or is it a code difference between Simon DOS and WIN?

comment:9 Changed 14 years ago by Kirben

The chest sprite (1627) is killed via vga script code and I see
no difference in that vga script code, when comparing DOS
and Windows versions of the game..
The sprite id's refer to different images in the DOS version
though, at least in this scene.
A workaround would not be possible.

I have not noticed any code difference in the related functions
when looking through disasm. of the game in the past.

comment:10 Changed 13 years ago by Kirben

It looks like the DOS versions of the game, handle draw
flag 0x4 differently, to allow sprites to be displayed in
situations like this.

comment:11 Changed 13 years ago by Kirben

Owner: set to Kirben

comment:12 Changed 12 years ago by Kirben

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 1
Summary: SIMON1DOS/TALKIE: Chest disappears at Swampling'sSIMON1DOS/TALKIE: Chest disappears at Swampling\'s

comment:13 Changed 12 years ago by Kirben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.