Opened 16 years ago

Closed 16 years ago

Last modified 13 months ago

#1278 closed defect (worksforme)

ALL: General protection fault on startup

Reported by: SF/halfgaar Owned by: SF/ender
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

When I startup scummvm, I immediatly get a general
protection fault. I've tried version 0.5.1 and a
snapshot of oktober 21 2003 23:22:42. My OS is Win98
first edition and I use the precompiled version.

This is the exact error:
SCUMMVM caused an invalid page fault in
module HID.DLL at 015f:7d06170d.
Registers:
EAX=00000072 CS=015f EIP=7d06170d EFLGS=00010216
EBX=00000072 SS=0167 ESP=009cf44c EBP=009cf68c
ECX=006a2ac4 DS=0167 ESI=0000005b FS=2137
EDX=009cf684 ES=0167 EDI=006a4fe8 GS=3bce
Bytes at CS:EIP:
f6 47 20 04 74 06 66 ff 42 3a eb 04 66 ff 42 3c
Stack dump:
000000b8 009cf938 00000000 7000d91b 006a2ac4 009cf684
009cf980 00000000 00000001 81b51a00 81b4da94 bff7dcb6
bff7dcbb 00000000 000000b8 00000000

Ticket imported from: #827560. Ticket imported from: bugs/1278.

Change History (11)

comment:1 by SF/ender, 16 years ago

Owner: set to SF/ender

comment:2 by SF/ender, 16 years ago

This sounds like a issue specific to your machine.

Unfortunatly I do not know anybody with a Win98 FE
installation. I do have access to a Win98SE install, and
will test this next week.

comment:3 by fingolfin, 16 years ago

Summary: General protection fault on startupALL: General protection fault on startup

comment:4 by SF/cloney, 16 years ago

Isn't HID.DLL to do with Human Interface Devices? Do you use
a USB mouse, Keyboard or Joystick?

Try running ScummVM with any of the above detached, and see
if that fixes it.

Failing that, try this:

1. Place the Windows98 CD in the drive. Go to Start -> Run,
then type "SFC" and hit enter.
2. Click 'Extract one file' and enter HID.DLL. Click start.
3. Enter the location of your Win98 CD-ROM in the 'Restore
From' field. If your PC is OEM and you don't have a proper
CD, try looking in "C:\Windows\Cabs". 'Save file in' should
read 'c:\windows\system'. When this is all entered, hit OK.
4. Now it will ask you to back up the HID.DLL file. Write
down the directory, then click on OK, then click yes to
create the Folder.
5. Now restart your PC and everything should now be OK.
Probably.

Hopefully. Google has lots of info about HID.DLL, it seems
it cocks up quite a lot.

Cloney

comment:5 by SF/halfgaar, 16 years ago

I do have HID devices attached to my computer. But
disconnecting the mouse is not effective. But I just
realized that Windows sees my monitor as HID device as well
(it's attached to the USB port). Disconnecting it solves the
problem.

It's still somewhat of a kludge-fix to me, and the question
remains whether this is scummvm's fault or not. What's more
likely, that it's scummvm's fault or something else?

comment:6 by fingolfin, 16 years ago

Yeah this looks like one of the "normal" joystick crashes.

Please dear original bug poster, test with a current daily build
(which can be downloaded from our homepage); they disable
joystick support by default. And then tell us whether that fixes the
problem or not. Thanks!

comment:7 by SF/halfgaar, 16 years ago

As I said, I've tried it with a daily build of oktober 21
and version 0.5.1. Just now I tried another daily build.
They all crash when my monitor is attached to the system.

comment:8 by SF/halfgaar, 16 years ago

I discovered something today. PowerDVD also makes an illegal
operation in HID.dll. So I guess it's not a problem in SCUMMVM

comment:9 by SF/ender, 16 years ago

Fhew :)

Closing as unreproducable / user dependent.

comment:10 by SF/ender, 16 years ago

Resolution: worksforme
Status: newclosed

comment:11 by digitall, 13 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.