Opened 4 months ago

Closed 4 months ago

#12773 closed feature request (fixed)

SQ1VGA: Toggle for ZZ Top?

Reported by: GermanTribun Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Space Quest 1

Description

SCUMMVM: 2.2.0
System: Windows 10

It's pretty well-known that Sierra was forced to censor ZZ Top in later versions of Space Quest I VGA.
https://www.movie-censorship.com/report.php?ID=5975600

Now, since the entire censorship hangs on the files 433.V56 and 533.V56, would it be possible that if these files are detected to have a little toggle in the game options available to turn off or on the censorship?

Right now ScummVM complains it's an altered version of the game.

Change History (5)

comment:1 by sluicebox, 4 months ago

ScummVM has no problem with you removing the two censorship view files. They're not part of our detection tables and I can add and run the game without them with no problems. Something is probably wrong on your end.

You could provide a screenshot and directory listing and we could try troubleshooting, but it's almost always the case that something is wrong with your resource files, or one is missing, or you've accidentally removed more files than you meant to. Assume your game directory is tainted and try copying from media / gog again.

I personally don't think adding an option to toggle the views is worth the effort given how easy it is to just remove the files, which is a well known thing. Also it starts to get complicated because not every version of SQ1VGA even has a censored ZZ Top; they eventually ripped the whole thing out.

But either way let's get your copy working first =)

Last edited 4 months ago by sluicebox (previous) (diff)

comment:2 by GermanTribun, 4 months ago

That was it. I re-copied it from my CD and removed the censor files and SCUMMVM no longer complains. Something must have gotten damaged over the years.

comment:3 by sluicebox, 4 months ago

Great, glad you got it working!

The more I think about this option the more I like it. Implementing it is easy (I just tried it); it can be cleanly and safely integrated into ResourceManager::isBlacklistedPatch().

The hard part (and the fun part) is coming up with a good name for the option, so I'll be thinking on that. I'd prefer avoiding mentioning any real-world names. =)

comment:4 by GermanTribun, 4 months ago

I would suggest naming the option "Original Cantina Band" and explain how the switch returns one of the three cantina bands to their original appearance as intended.

comment:5 by sluicebox, 4 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

We discussed it and decided that this is a silly option.

So I did it: https://github.com/scummvm/scummvm/commit/af7d05999e944ffc446078054ed3b8a7a347e228 =)

The new option will appear in the next daily build. You'll have to remove and re-add the game for the new option to appear under the Engine tab.

Thanks!

Note: See TracTickets for help on using tickets.