#12772 closed defect (wontfix)

SQ1VGA: Messed-up Game Over-screen

Reported by: GermanTribun Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: original
Cc: Game: Space Quest 1

Description

ScummVM: 2.2.0
System: Windows 10 Pro

In the SCI-version of Space Quest I when pushing the wrong button in the escape pod and crashing at Nottingham Castle, the Game Over-screen with the skeleton is messed up.

The picture looks like its for an EGA-version of the game (picture is attached). Since the same also happened in the original interpreter and other deaths use the correct VGA picture, it's clear the game in this instance uses the wrong resource.

Can that be fixed so that this scene uses the correct VGA picture?

Attachments (1)

scummvm-sq1sci-00000.png (56.5 KB ) - added by GermanTribun 14 months ago.

Download all attachments as: .zip

Change History (4)

by GermanTribun, 14 months ago

Attachment: scummvm-sq1sci-00000.png added

comment:1 by sluicebox, 14 months ago

Keywords: original added

This looks like a palette conflict between the room's picture and that death view. I'll take a deeper look later to see if we can do something about it. Thanks for reporting this.

comment:2 by sluicebox, 14 months ago

Confirmed: the Longbow castle picture has the "wrong" palette entries for 48-63, which prevents the game-over view from using the right colors, but they changed those colors to achieve the rainbow palette animation for the hyperspace hole that the ship comes out of. It animates colors 48-70.

I don't know what can be done about this. There aren't enough colors, which Sierra probably noticed but just lived with.

Last edited 14 months ago by sluicebox (previous) (diff)

comment:3 by sluicebox, 12 months ago

Owner: set to sluicebox
Resolution: wontfix
Status: newclosed

Closing as this is original behavior due to the game using all of the palette slots in this room. Those rainbows ain't free!

Note: See TracTickets for help on using tickets.