Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#12769 closed defect (fixed)

Gemini Rue (AGS) fails to start with runtime error

Reported by: Paolo86cripple Owned by: dreammaster
Priority: high Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

When launching gemini rue, it crashes at startup with the following script error:

Unresolved import 'Object::get_Solid' in 'room125.asc'
Unable to create local script: Runtime error: in room125.asc: 1 unresolved imports (last: Object::get_Solid)!

Using scummvm on manjaro linux using the latest ags code.

Change History (5)

comment:1 by pa-august, 4 months ago

I have the same error with QfG 2 VGA.

edit: I'm on Windows 11

User picked target 'qfg2agdi' (engine ID 'ags', game ID 'qfg2agdi')...
   Looking for a plugin supporting this target... Adventure Game Studio
WARNING: TODO: SetCurrentDirectory: C:\LocalGames\Quest for Glory II\!
Initializing backend libs
Initializing game data
Opened game data file: game28.dta
Game data version: 42
Compiled with: 3.2.0
Startup directory: ./
Data directory: ./
Setting up game configuration
WARNING: File::open: 'C:\LocalGames\Quest for Glory II\speech.vox' does not exist!
WARNING: File::open: 'C:\LocalGames\Quest for Glory II\speech.vox' does not exist!
Voice pack was not found, but explicit voice directory is defined: enabling voice-over.
audio.vox found and initialized.
Initializing TTF renderer
Initializing mouse: number of buttons reported is 3
Install timer
Initialize legacy path finder library
Game title: 'Quest for Glory II'
Game GUI version: 115
unresolved import 'Object::get_Solid' in 'Module0.asc'
Last edited 4 months ago by pa-august (previous) (diff)

comment:2 by criezy, 4 months ago

I am unable to reproduce those issues on macOS. Both Gemini Rue (version from GoG) and QfG II VGA start for me without errors.

comment:3 by Paolo86cripple, 4 months ago

The copy I use is from GOG as well. Crash occurs immediately after the wadjet eye logo. Will try pulling the latest code even if no ags code is modified and get back to you.

comment:4 by dreammaster, 4 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

The problem is now fixed. There was an accidentally removed function export; it's now been re-added.

comment:5 by criezy, 4 months ago

Ah that explains it. I see it was removed 3 days ago and the code I was using yesterday to test was probably a few days old and still had that function export (I actually checked the export was present in the code). Next time I will try to remember to get the latest code to test reported bugs ;-)

Note: See TracTickets for help on using tickets.