Opened 2 years ago

Closed 6 months ago

#12767 closed defect (worksforme)

AGS: Blackwell Convergence: Gothic Bridge BGM does not start

Reported by: Paolo86cripple Owned by:
Priority: normal Component: Engine: AGS
Version: Keywords: ags, music, blackwell3
Cc: Game:

Description

Whenever you reach the Gothic Bridge, the location background music does not start. An heightened volune version of the map screen theme is played instead. The debug message WARNING: channel 2 - same clip assigned is shown.

Using a self compiled build on Manjaro Linux.

Attachments (1)

blackwell3.006 (231.6 KB ) - added by tag2015 8 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by Paolo86cripple, 2 years ago

Keywords: bw3 added; bw2 removed

comment:2 by dreammaster, 2 years ago

Thanks for the report. It's been a while.. is the Bridge right at the start of the game? I can't remember. If not, a savegame from before approaching the bridge would be helpful.

comment:3 by dreammaster, 2 years ago

Owner: set to dreammaster
Resolution: pending
Status: newpending

comment:4 by dreammaster, 2 years ago

Summary: Blackwell Convergence (AGS) Gothic Bridge BGM does not startAGS: Blackwell Convergence: Gothic Bridge BGM does not start

by tag2015, 8 months ago

Attachment: blackwell3.006 added

comment:5 by tag2015, 8 months ago

Using latest git version on Win10, I can't reproduce the issue (using latest GOG/Steam version).

I attached a save. Just leave the room to access the map and then go to the Gothic Bridge

comment:6 by tag2015, 7 months ago

@dreammaster
Maybe this can be closed? I don't know if it was a ScummVM bug or an upstream bug that was fixed in the meantime, but I can't reproduce it at all, at gothic bridge or other locations.

comment:7 by dreammaster, 6 months ago

Owner: dreammaster removed

comment:8 by Thunderforge, 6 months ago

Keywords: blackwell3 added; bw3 removed
Resolution: pendingworksforme
Status: pendingclosed

I assume the reproduction steps are:

  1. Load the attached save
  2. Exit the room
  3. Choose "Gothic Bridge" as a new location

Then the bug report says the background music shouldn't start and WARNING: channel 2 - same clip assigned appears in the logs.


I just tested this on 2.8.0 Daily 2023-06-09 and could not reproduce the issue. The music loaded properly and the expected warning did not appear in the logs.

Since both @tag2015 and I couldn't reproduce it, I'm going to close the bug.

Note: See TracTickets for help on using tickets.