#12764 closed defect (fixed)

AGS: Lamplight City - pencil and calender puzzle apparently does not work.

Reported by: Sslaxx Owned by: dreammaster
Priority: high Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

Lamplight City version 1.12 (last version on Steam), on Linux. ScummVM build 2.3.0git21136.

The puzzle in case 5, where you have to uncover calender dates using a pencil, appears to be faulty. It seems to work for one of the dates, but the other cannot be made to trigger no matter how much you "draw" over the top of the calender.

Attachments (2)

lamplightcity.000.7z (1.1 MB ) - added by Sslaxx 14 months ago.
lamplightcity.011.7z (983.1 KB ) - added by Sslaxx 14 months ago.

Change History (11)

by Sslaxx, 14 months ago

Attachment: lamplightcity.000.7z added

comment:1 by Sslaxx, 14 months ago

As of git21438 this no longer seems to trigger anything at all; no matter how much you "draw" on top of the calender, neither event triggers.

Last edited 14 months ago by Sslaxx (previous) (diff)

comment:2 by Sslaxx, 14 months ago

Priority: normalhigh

comment:3 by dreammaster, 14 months ago

Hmmm.. do you have a savegame from before you started drawing? That way I can try it in an earlier version to see the first date triggering, and compare it to why it's not triggering now. That should help me zero in on what changed.

in reply to:  3 comment:4 by Sslaxx, 14 months ago

Replying to dreammaster:

Hmmm.. do you have a savegame from before you started drawing? That way I can try it in an earlier version to see the first date triggering, and compare it to why it's not triggering now. That should help me zero in on what changed.

Well, I found that on one occasion I could get neither to trigger, trying it again one did trigger but not the other, so I'm not sure how consistently reproducible this bug is.

comment:5 by dreammaster, 14 months ago

Well, as I said, any savegame just prior to the puzzle will be helpful in investigating the matter further.

in reply to:  5 comment:6 by Sslaxx, 14 months ago

Replying to dreammaster:

Well, as I said, any savegame just prior to the puzzle will be helpful in investigating the matter further.

Going to add one, hope it helps.

by Sslaxx, 14 months ago

Attachment: lamplightcity.011.7z added

comment:7 by dreammaster, 14 months ago

It has thanks. It took me a little while, because I was getting crashes on the standalone AGS interpreter, and couldn't do comparisons, but I've resolved it, and now can.

I narrowed the problem. The script at offset 3428 calls Sc_DrawingSurface_GetPixel(x = 367, y = 288), and then compares the resulting rgb16 value to 8419 exactly. That's an incredibly specific color, and I guess it represents the shading resulting from blending the calendar background and the "pencil mark sprite" to gradually darken the calendar by specific increments. The trouble is that our current blending isn't 100% precisely equal to the original Allegro routine that AGS standalone uses, so doesn't reach that exact value.

Fixing it will, I guess, tie into blending optimizations. At least that particular special case. I'll have to look into replicating the Allegro original routine exactly.

comment:8 by sev-, 14 months ago

Summary: Lamplight City - pencil and calender puzzle apparently does not work.AGS: Lamplight City - pencil and calender puzzle apparently does not work.

comment:9 by dreammaster, 14 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Fixed. The blending now precisely replicates the original, and both days on the calendar are triggered when completely darkened

Note: See TracTickets for help on using tickets.