#12760 closed defect (invalid)

BACKENDS: 3DS: Significant regression // All games broken

Reported by: MarioKartFan Owned by: MarioKartFan
Priority: high Component: Port: 3DS
Version: Keywords:
Cc: Game:

Description

Latest nightlies no longer work on the 3DS. It returns an ERROR on launch of game “Unknown res tag ‘.W.0’ encounter”. That’s the best case scenario - for SCUMM games. For SCI32 games it now returns an Arm11 error.

Change History (13)

comment:1 by ccawley2011, 11 months ago

Component: --Unset--Port: 3DS

Do you know what the last version that worked was? Also, could you list which SCUMM and SCI32 games you've tested with?

comment:2 by sev-, 11 months ago

Priority: normalhigh

This would be nice to get fixed before the release.

comment:3 by MarioKartFan, 11 months ago

I tested this with Monkey Island 2, Day of the Tentacle, and QFG IV. I tested again using the latest daily build and had the same result.

It worked a few months ago. I do not know how to download older nightlies from buildbot. If I did, I could try and figure out what version introduced the error.

comment:4 by sev-, 11 months ago

Summary: 3DS Port: Significant regression // All games brokenBACKENDS: 3DS: Significant regression // All games broken

comment:5 by ccawley2011, 10 months ago

Are those two engines the only ones that are affected, or are all engines broken?

comment:6 by tag2015, 10 months ago

Can't reproduce.
I just installed the .3dsx and the .cia versions (installed using fbi 2.6) of the latest dev (cdbc05e0) and found no problems on my 3ds xl.
I tried maniac mansion v2, monkey island 2, larry 1, dreamweb and space quest 6.
Did you try removing and re-adding the titles to the list using the default options?

comment:7 by MarioKartFan, 10 months ago

Yes. Tried with latest build just now. Removed ini. Readied games. Same errors. Also now get an Arm11 error when using the built in returning to launcher function. Issue is present on N3DS, N2DSXL and N3DSXL.

comment:8 by MarioKartFan, 10 months ago

Might be related to this error from a year or so ago that I reported and that @bgk fixed. Both had the “unknown res tag” issue.

https://bugs.scummvm.org/ticket/11342

comment:9 by ccawley2011, 10 months ago

I've put together a test build which includes a statically linked version of ScummVM containing only the SCUMM and SCI engines, along with debug symbols: https://drive.google.com/file/d/1Fd74HrVlJO9ZcIrb0yAH3-rey2ovtNlJ/view?usp=sharing

If it works, it means the issue is related to the dynamic plugin system in some way. If it doesn't, could you provide a backtrace and logs using these instructions? https://wiki.scummvm.org/index.php?title=Nintendo_3DS#Debugging_ScummVM

comment:10 by MarioKartFan, 10 months ago

Thanks for the special build. Same result unfortunately. Will provide a backtrack and logs tomorrow. Thanks for the help.

comment:11 by tag2015, 10 months ago

Still can't reproduce. These are my specs:
3DS XL
System 11.15.0-47E (europe)
Payload Luma3DS 10.2.1-c058e3f
Homebrew Menu 2.2.0

I can run the games you mentioned using the .3dsx version 2.3.0pre 74ffddd8 (built sept 1), started using HB loader.
Are you sure your system is up to date and the SD card is fine?
You said that the issue is present on different consoles, did you try those yourself?

comment:12 by MarioKartFan, 10 months ago

Thanks to everyone for the support. Based on the latest post from tag2015 I retired my games from my original CDs and re-encoded with FLAC the relevant files. Basically recreated my collection from scratch. I confirm that these files are working as expected on all three of my systems. Still inspecting but it looks like my SD card in my main system is failing and as I copied files from it to the SD cards for my other systems the files were corrupted all around d.

I apologize for the distraction. I think this can be closed.

comment:13 by MarioKartFan, 10 months ago

Owner: set to MarioKartFan
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.