Opened 2 weeks ago

Closed 3 days ago

#12752 closed defect (wontfix)

AGS: Game crashing script error when exiting Rosa's notes by clicking offscreen (Blackwell Legacy)

Reported by: Paolo86cripple Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords: ags, blackwell1, script hung
Cc: Game:

Description

The game crashes whenever you try to exit Rosa's notes by clicking the outside of the notepad instead of the red X (Close) button on the notebook. Closing with the button does not reproduce the bug

Debug console output is as follows:

ERROR: !Error running function 'btn_notes_Click':
Error: Script appears to be hung (a while loop ran 150001 times). The problem may be in a calling function; check the call stack.
!
Running Scummvm with the most recent code as of July 19th on a self compiled build on Manjaro Linux. (all engines enabled, discord integration disabled, release mode enabled).

Attachments (1)

blackwell1.004 (834.4 KB ) - added by dreammaster 3 days ago.

Download all attachments as: .zip

Change History (4)

comment:1 by Paolo86cripple, 2 weeks ago

Keywords: ags blackwell1 script hung added

comment:2 by dreammaster, 3 days ago

Congrats. You seem to have stumbled across a bug in the original game. I got the same error using the bundled AGS interpreter. I'll have a little further look to see if there's a way to cleanly work around the game script problem.

by dreammaster, 3 days ago

Attachment: blackwell1.004 added

comment:3 by dreammaster, 3 days ago

Owner: set to dreammaster
Resolution: wontfix
Status: newclosed
Summary: Game crashing script error when exiting Rosa's notes by clicking offscreen (Blackwell Legacy)AGS: Game crashing script error when exiting Rosa's notes by clicking offscreen (Blackwell Legacy)

The game script seems to be an extensive one, so it's unfeasible to devote time to a workaround right now, particularly since the obvious X button works for now. So I'm going to close it as "will not fix". But just for posterity sake, in case anyone wants to come back to it later, I've attached a savegame when Rosa already has the notebook.

Also, the script in question goes into a loop that starts 6727 (line 548 of the game script), and goes through to offset 7218, where it does a jmp back to 6727. I'm presuming that it represents an event processing loop, and because you clicked outside the notebook, it goes into the infinite loop because it doesn't have anything to handle it.

Note: See TracTickets for help on using tickets.