Opened 3 months ago

Closed 3 months ago

#12738 closed defect (duplicate)

Strangeland (AGS) fails to start

Reported by: Paolo86cripple Owned by: criezy
Priority: blocker Component: Engine: AGS
Version: Keywords: ags, strangeland, null pointer
Cc: Game:

Description

Strangeland fails to initialize after it is properly detected. Launching it results in the following debug messages:

User picked target 'strangeland' (engine ID 'ags', game ID 'strangeland')...

Looking for a plugin supporting this target... Adventure Game Studio

Connected to Alsa sequencer client [14:0]
ALSA client initialized [128:0]
WARNING: TODO: SetCurrentDirectory: /home/paolothebastard/Downloads/scvmgames/strangeland!
Initializing backend libs
Initializing game data
Opened game data file: game28.dta
Game data version: 50
Compiled with: 3.5.0.26
Startup directory: ./
Data directory: ./
Setting up game configuration
Voice pack found and initialized.
audio.vox found and initialized.
Initializing TTF renderer
Initializing mouse: number of buttons reported is 3
Install timer
Initialize path finder library
Game title: 'Strangeland'
Game GUI version: 119
Requested script API: v3.5.0-final (7), compat level: v3.5.0-final (7)
Plugin 'agsgalaxy' loaded as 'agsgalaxy.dll', resolving imports...
Plugin 'agswaves' loaded as 'agswaves.dll', resolving imports...
AchievementsManager::unsetActiveDomain()
Checking for disk space
Game native resolution: 640 x 360 (32 bit)
Graphic settings: driver: D3D9, windowed: yes, screen def: max, screen size: 0 x 0, match device ratio: ignore, game scale: max_round
Requested graphics driver 'D3D9' not found, will try existing drivers instead
Mouse speed control: disabled, unit: 1.000000, user value: 1.000000
Setting up window
Initialize sprites
Engine initialization complete
Starting game
WARNING: channel 2 - same clip assigned
!Error running function 'game_start':
Error: Null pointer referenced
!
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: !Error running function 'game_start':
Error: Null pointer referenced

Running the game on a ScummVM daily build with code updated as of July 14th, 2021 on Manjaro Linux with all engines enabled and discord integration disabled.

The game was purchased on GOG and files were extracted with innoextract 1.9.

Change History (1)

comment:1 by criezy, 3 months ago

Owner: set to criezy
Resolution: duplicate
Status: newclosed

Thank you for the report. This is a duplicate of ticket #12729 though, so I am closing this one. You can follow the progress on the fix in that other ticket.

Note: See TracTickets for help on using tickets.