Opened 7 months ago

Closed 7 months ago

#12718 closed defect (fixed)

PRIVATE: New location doesn't appear after required actions

Reported by: TrivialBalderdash Owned by: neuromancer
Priority: high Component: Engine: Private
Version: Keywords:
Cc: Game: Private Eye

Description (last modified by TrivialBalderdash)

When testing with the latest nightly build, I was unable to progress to the Van Nuys Hotel. I'd get the phone call telling me to come to the hotel, but the map location wouldn't show up.

Interestingly, if I ignore the call and go to a different location instead, I can proceed. In that case, when I come back to the map/phone/notepad scene, the phone will ring again. If I answer it, I get the same message inviting me to the hotel and the location does show up.

If I answer the call the first time, I'm stuck and can't proceed. If I ignore the call and answer it later, I can proceed.

This is with the Mac OS X (Intel x64) July 3 nightly build. I went back and tested on the June 21 build and this issue wasn't present.

The sequence of events I used:

  • Original Plot, click Start
  • Click on Orin in the photo
  • Go to Cal Western
    • Click on the file
  • Go to Idaho St.
    • Click on the door
    • Click on the bottles to wake the landlord
    • Click on the suitcase
    • Examine the ice pick, but don't take it
    • Take film canister
    • Take phone number
  • Back to office
    • Click on Orfamay
    • Leave Office (<-- attached saved game at this point)
  • Answer Phone
  • Check Map of Van Nuys Hotel

Attachments (2)

Private Eye Van Nuys.png (1.4 MB ) - added by TrivialBalderdash 7 months ago.
private-eye-win-us.016 (4.7 KB ) - added by TrivialBalderdash 7 months ago.

Download all attachments as: .zip

Change History (9)

by TrivialBalderdash, 7 months ago

Attachment: Private Eye Van Nuys.png added

comment:1 by neuromancer, 7 months ago

Uhm, using the save game, I cannot reproduce this issue with the US version (that's the one you should be using, considering the name of save game). Before answering the phone, the map don't show the hotel. As soon as I click on the phone, the location shows in the map.

However, following the instructions step by step, I managed to reproduce the issue. Let's take a look.

comment:2 by neuromancer, 7 months ago

I think I just fixed this the latest revision but to test it you will need to do every step, or save it before the last step, otherwise loading your save game does not expose the issue (the internal symbols are automatically resolved when a game is loaded and the phone symbol is already ready to be used).

PD: you know that you can click on the "frame" at any point of game to save using the notebook, right?

comment:3 by TrivialBalderdash, 7 months ago

Description: modified (diff)

You're right about the save file, it doesn't reproduce the issue when loaded. Sorry about that, I thought I tested it after saving.

I created a new file, saved in Marlowe's office just before the phone call. (Thanks for the tip about the frame, I forgot about that feature.) When I load it after restarting ScummVM, I can reproduce the issue.

I noticed something today while testing. ScummVM crashes when trying to start a new game from within the game (on the notepad). Do you want me to create a new ticket? I can confirm that the June 21 nightly build doesn't have this issue.

Assertion failed: (_map.contains(name)), function load, file /data/src/master/engines/private/code.cpp, line 85.
Abort trap: 6

by TrivialBalderdash, 7 months ago

Attachment: private-eye-win-us.016 added

in reply to:  3 comment:4 by neuromancer, 7 months ago

Replying to TrivialBalderdash:

You're right about the save file, it doesn't reproduce the issue when loaded. Sorry about that, I thought I tested it after saving.

No problem.

I created a new file, saved in Marlowe's office just before the phone call. (Thanks for the tip about the frame, I forgot about that feature.) When I load it after restarting ScummVM, I can reproduce the issue.

You try compiling the latest revision after my commits? It looks fixed to me.

I noticed something today while testing. ScummVM crashes when trying to start a new game from within the game (on the notepad). Do you want me to create a new ticket? I can confirm that the June 21 nightly build doesn't have this issue.

Assertion failed: (_map.contains(name)), function load, file /data/src/master/engines/private/code.cpp, line 85.
Abort trap: 6

Uhm, this is somehow expected. I will try to fix it right now, so need to create another ticket.

in reply to:  3 comment:5 by neuromancer, 7 months ago

Assertion failed: (_map.contains(name)), function load, file /data/src/master/engines/private/code.cpp, line 85.
Abort trap: 6

I think this should be fixed in the last revision (https://github.com/scummvm/scummvm/commit/366cd0470420f1c96526fe08e8a40c8cb071e228). Please pull, recompile and test.

comment:6 by TrivialBalderdash, 7 months ago

Both issues are fixed. Thank you!

comment:7 by neuromancer, 7 months ago

Resolution: fixed
Status: newclosed

Thanks for the reports!

Note: See TracTickets for help on using tickets.