#12707 closed defect (duplicate)

AGS: Computer-driven cars moving too slowly in Super Pitstop Racing

Reported by: GateKeeper-Adventurer Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: GateKeeper-Adventurer Game:

Description (last modified by GateKeeper-Adventurer)

In Super Pitstop Racing three racing cars driven by the computer are moving too slowly.

Running the game normally in AGS, winning the race against other cars is quite challenging. When running the game in ScummVM, other cars can be overlapped already on the second lap, and many times during the race.

The entire game runs more slowly in ScummVM than in real AGS environment, but even taking that into account, the competing cars are moving too slowly relative to the player's car.

Change History (2)

comment:1 by GateKeeper-Adventurer, 12 months ago

Description: modified (diff)

comment:2 by dreammaster, 11 months ago

Owner: set to dreammaster
Resolution: duplicate
Status: newclosed

I tested the game with a Release build and confirmed that the speed was comparable to the standalone AGS interpreter. Since there's already a story for improving game performance on debug builds, I'm going to close this story as a duplicate.

Note: See TracTickets for help on using tickets.