Opened 16 years ago

Closed 16 years ago

Last modified 12 months ago

#1270 closed defect (fixed)

GUI: Launcher crashes with unexisting targets

Reported by: SF/einheitlix Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

I noticed that the ScummVM launcher crashes if one tries to edit /
play a target in the list which doesn't exist.

For example, let's say someone want to get everything ready for
when Broken Sword 1 is supported (that's not how I discovered it, but
I'm trying to give a plausible example why this could happen to
someone ;-)).

He edits the configuration file manually and enters information about
his Broken Sword 1 (path, fullscreen, etc.).

Now when you chooses this entry in the list in the ScummVM
launcher and clicks on "Edit Game..." or "Start", the whole program
crashes!

I mean, ok, I suppose one could argue that we're not supposed to
enter targets which are not supported - but is it really necessary that
the whole thing crashes when you do it (it says "Fatal signal:
Segmentation Fault (SDL Parachute Deployed)" when you click on
"Edit Game...")? Wouldn't a nice error message in the GUI be better
("Target unknown!" or something like that)? It's only one list entry
within dozens of them, and the whole ScummVM crashes because he
doesn't like ONE target :-(

Just a thought, I just feel it's a bit "scruffy" this way...

Ticket imported from: #821502. Ticket imported from: bugs/1270.

Change History (6)

comment:1 by fingolfin, 16 years ago

Owner: set to fingolfin
Summary: Launcher crashes with unexisting targetsGUI: Launcher crashes with unexisting targets

comment:2 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by SF/einheitlix, 16 years ago

Right. I didn't mention those things, as I thought it was a more generic bug.
But I had a closer look at it now.

"* ScummVM version (PLEASE test the latest CVS/Daily build)
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made."

Well, the stable release (ScummVM 0.5.1) doesn't crash when you click on
"Edit Game..." with an invalid target. So it actually seems to be a regression.

But it already happens with the oldest build I could get hold of (2003/10/05).
It also still happens with the latest CVS build.

So it must be a regression which happened between 2003/08/08 (when 0.5.
1 was released) and 2003/10/05 (which is the oldest build I could get and
where it happens).

I'm willing to test all the builds from August 8th to October 5th to tell you
exactly where it happens if only I knew how possibly I could get hold of all
these versions :-)

"* Bug details, including instructions on reproducing it "

Uhm.... well, I mentioned these things in my original bug report. Isn't it
sufficient to reproduce it? I don't know what else I could mention really.

"* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Attach a save game if possible "

Max, it's not a bug concerning a game, it's a bug concerning the ScummVM
GUI launcher. Which is why I put it in the "LucasArts or *Generic* bugs" bug
list.

"* Platform and Compiler (Win32, Linux, MacOS, ...) "

malte@fuchur:~> uname -a
Linux fuchur 2.4.20-4GB-athlon #1 Wed Aug 6 18:27:52 UTC 2003 i686
unknown unknown GNU/Linux

Note that I think it's not a platform related bug. I'll test it with Win32 later to
check it out.

Hope this helps...

comment:4 by fingolfin, 16 years ago

Malte, please realize that this is not a reply I wrote esp. for you.
It's a generic template. And it actually just repeats what we ask
for on the bug submission page. We have it because many people
don't read that information at all, or only read it incompletely ;-)

comment:5 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 12 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.