#12640 closed defect (fixed)

TRECISION: Visual glitch when opening door in Hugh's virtual office

Reported by: Kurufinwe21 Owned by: bluegr
Priority: normal Component: Engine: Trecision
Version: Keywords:
Cc: Game: Nightlong: Union City Conspiracy

Description

ScummVM 2.3.0git18795-gb06eec0a4b (Jun 14 2021 05:38:16) on Windows 10 21H1 x64.

Playing Nightlong (Windows, French version, i.e. English voices with French UI/subtitles).

When opening the doors in Hugh's conference room, the open doorway in superimposed over the animation of the doors opening.

Things go back to normal once the door is opened.

Attachments (2)

scummvm-nl-win-fr-00014.png (413.8 KB ) - added by Kurufinwe21 11 months ago.
Screenshot
nl-win-fr.007 (45.2 KB ) - added by Kurufinwe21 11 months ago.
Savegame. Right-click the doors on the right to reproduce.

Download all attachments as: .zip

Change History (3)

by Kurufinwe21, 11 months ago

Attachment: scummvm-nl-win-fr-00014.png added

Screenshot

by Kurufinwe21, 11 months ago

Attachment: nl-win-fr.007 added

Savegame. Right-click the doors on the right to reproduce.

comment:1 by bluegr, 11 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for your report!

This has now been fixed in df607c7f8db5d9bfb885c7502c0af0a5826b4ce5:
https://github.com/scummvm/scummvm/commit/df607c7f8db5d9bfb885c7502c0af0a5826b4ce5

It has the same root cause as #12629 and #12639: the action animation rects were not calculated correctly.

The fix will be available in the next daily version of ScummVM

Note: See TracTickets for help on using tickets.