Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#12639 closed defect (fixed)

TRECISION: Visual glitch when looking down the well (amusement park)

Reported by: Kurufinwe21 Owned by: bluegr
Priority: normal Component: Engine: Trecision
Version: Keywords:
Cc: Game: Nightlong: Union City Conspiracy

Description

ScummVM 2.3.0git18795-gb06eec0a4b (Jun 14 2021 05:38:16) on Windows 10 21H1 x64.

Playing Nightlong (Windows, French version, i.e. English voices with French UI/subtitles).

In the amusement part, in the castle courtyard, right-clicking the well makes Joshua partly disappear as he looks down the well.

Attachments (3)

scummvm-nl-win-fr-00012.png (422.8 KB ) - added by Kurufinwe21 11 months ago.
Screenshot. Only Joshua's leg is visible (left of the well)
nl-win-fr.007 (41.1 KB ) - added by Kurufinwe21 11 months ago.
Savegame. Right-click the well to reproduce.
scummvm-nl-win-fr-00013.png (357.1 KB ) - added by Kurufinwe21 11 months ago.
Screenshot when grabbing the sulphur in the study

Download all attachments as: .zip

Change History (8)

by Kurufinwe21, 11 months ago

Attachment: scummvm-nl-win-fr-00012.png added

Screenshot. Only Joshua's leg is visible (left of the well)

by Kurufinwe21, 11 months ago

Attachment: nl-win-fr.007 added

Savegame. Right-click the well to reproduce.

comment:1 by Kurufinwe21, 11 months ago

Something similar happens when grabbing the jar of sulphur in the study. (The same save can be used to reproduce the bug.)

by Kurufinwe21, 11 months ago

Attachment: scummvm-nl-win-fr-00013.png added

Screenshot when grabbing the sulphur in the study

comment:2 by bluegr, 11 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for your report!

Both glitches were caused from Joshua's dirty rect
being calculated incorrectly, thereby messing up
his action animations.

Both issues have been fixed in commit 3297cb2669eb4072e7e3ca3e5c5b14b5e7d918ec:
https://github.com/scummvm/scummvm/commit/3297cb2669eb4072e7e3ca3e5c5b14b5e7d918ec
and should be in the next ScummVM daily build

comment:3 by Kurufinwe21, 11 months ago

Resolution: fixed
Status: closednew

Are you sure this is fixed?

I'm using build 2.3.0git18903-g313a824fb9 which should have the fix (it definitely has the fix for bug #12638, which was committed after the fix for this bug), and the bug still occurs exactly as before (both the well and the sulphur).

comment:4 by bluegr, 11 months ago

Thanks for the feedback

I had tried with my own saved games. I've tried with yours now, and I can reproduce the glitches.

The issue with the well only occurs sometimes. The issue with the jar is more frequent.
This will need more investigation

comment:5 by bluegr, 11 months ago

Resolution: fixed
Status: newclosed

Thanks for your report!

This has now been fixed in df607c7f8db5d9bfb885c7502c0af0a5826b4ce5:
https://github.com/scummvm/scummvm/commit/df607c7f8db5d9bfb885c7502c0af0a5826b4ce5

It has the same root cause as #12629 and #12640: the action animation rects were not calculated correctly.

The fix will be available in the next daily version of ScummVM

Last edited 11 months ago by bluegr (previous) (diff)
Note: See TracTickets for help on using tickets.