#12629 closed defect (fixed)

TRECISION: Visual glitch with dinosaur head in zoo

Reported by: Kurufinwe21 Owned by: bluegr
Priority: normal Component: Engine: Trecision
Version: Keywords:
Cc: Game: Nightlong: Union City Conspiracy

Description

ScummVM 2.3.0git18734-g759f82c78a (Jun 12 2021 17:24:26) on Windows 10 21H1 64-bit.

Playing Nightlong (Windows, French version, i.e. English voices with French UI/subtitles).

Using the attached save, left-click on the dinosaur head at the bottom-right of the screen. Joshua plays with it a bit. As that happens, most of the head vanishes (the nose sticks around and is animated).

Once the animation finishes, the head reappears.

Attachments (1)

nl-win-fr.005 (40.3 KB ) - added by Kurufinwe21 13 months ago.
Savegame. Click the dino head at the bottom right.

Download all attachments as: .zip

Change History (2)

by Kurufinwe21, 13 months ago

Attachment: nl-win-fr.005 added

Savegame. Click the dino head at the bottom right.

comment:1 by bluegr, 13 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for your report!

This has now been fixed in df607c7f8db5d9bfb885c7502c0af0a5826b4ce5:
https://github.com/scummvm/scummvm/commit/df607c7f8db5d9bfb885c7502c0af0a5826b4ce5

It has the same root cause as #12639 and #12640: the action animation rects were not calculated correctly.

The fix will be available in the next daily version of ScummVM

Note: See TracTickets for help on using tickets.