Opened 7 months ago

Closed 7 months ago

#12626 closed defect (fixed)

TRECISION: Chain seems to already be hanging from pipe when first entering Rotmall 17 station

Reported by: Kurufinwe21 Owned by: bluegr
Priority: normal Component: Engine: Trecision
Version: Keywords:
Cc: Game: Nightlong: Union City Conspiracy

Description (last modified by Kurufinwe21)

ScummVM 2.3.0git18721-g8c0c91fe94 (Jun 12 2021 03:56:50) on Windows 10 21H1 64-bit.

Playing Nightlong (Windows, French version, i.e. English voices with French UI/subtitles).

When you enter the deserted Rotmall 17 station, your first goal is to cross to the other side of the tracks. The way to do that is to tie a chain to an overhead pipe and swing across.

However, when you first enter the station, the chain is already displayed as hanging from the pipe. This is only a visual bug: the chain not clickable and thus doesn't let you skip the puzzle, but it shouldn't be shown until the puzzle has been solved.

Might be related to bug #12624?

Attachments (1)

nl-win-fr.003 (39.0 KB ) - added by Kurufinwe21 7 months ago.
Savegame. Go right to enter the station.

Download all attachments as: .zip

Change History (4)

by Kurufinwe21, 7 months ago

Attachment: nl-win-fr.003 added

Savegame. Go right to enter the station.

comment:1 by Kurufinwe21, 7 months ago

Description: modified (diff)

comment:2 by Kurufinwe21, 7 months ago

The bug also happens in the zoo, in the dinosaur exhibit. When you first enter the room after the force field has been deactivated, the mechanical dinosaur is already displayed. It's not moving and not treated as a hotspot.

Once you try to cross the bridge, the cutscene in which the dino is supposed to appear plays, and the dinosaur appears properly (animated, clickable) afterwards.

comment:3 by bluegr, 7 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for reporting this

It has the same root cause as bug #12624
Both issues have been fixed in 039cf08f4fdbbf05798cbf22cec38f7ce76fbda9:
https://github.com/scummvm/scummvm/commit/039cf08f4fdbbf05798cbf22cec38f7ce76fbda9

The fix shall be in the next daily build

Note: See TracTickets for help on using tickets.