Opened 4 months ago

Closed 3 weeks ago

#12624 closed defect (fixed)

TRECISION: Woman at the liquor store frozen in place instead of leaving the room

Reported by: Kurufinwe21 Owned by: bluegr
Priority: normal Component: Engine: Trecision
Version: Keywords:
Cc: Game: Nightlong: Union City Conspiracy

Description

ScummVM 2.3.0git18721-g8c0c91fe94 (Jun 12 2021 03:56:50) on Windows 10 21H1 64-bit.

Playing Nightlong (Windows, French version, i.e. English voices with French UI/subtitles).

At the liquor store, in the cellar, when you use the rat on the woman, a cutscene plays during which she runs out of the room. However, once the cutscene ends, she appears still in place, but no longer moves nor counts as a hotspot.

Leaving the room and re-entering doesn't fix the problem. Neither does saving and reloading.

Skipping the cutscene (with ESC) or watching it fully doesn't make a difference.

Attachments (2)

nl-win-fr.003 (38.7 KB ) - added by Kurufinwe21 4 months ago.
Savegame. Use the rat on the woman to trigger the bug.
Nightlong Cellar.jpg (325.1 KB ) - added by TrivialBalderdash 6 weeks ago.

Download all attachments as: .zip

Change History (5)

by Kurufinwe21, 4 months ago

Attachment: nl-win-fr.003 added

Savegame. Use the rat on the woman to trigger the bug.

comment:1 by bluegr, 4 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Thanks for reporting this

It has the same root cause as bug #12626
Both issues have been fixed in 039cf08f4fdbbf05798cbf22cec38f7ce76fbda9:
https://github.com/scummvm/scummvm/commit/039cf08f4fdbbf05798cbf22cec38f7ce76fbda9

The fix shall be in the next daily build

comment:2 by TrivialBalderdash, 6 weeks ago

Resolution: fixed
Status: closednew

This issue still occurs in the 2.3.0pre stable release from August 30. I'm playing on MacOS x64 using the US version of the game (Windows/English).

by TrivialBalderdash, 6 weeks ago

Attachment: Nightlong Cellar.jpg added

comment:3 by bluegr, 3 weeks ago

Resolution: fixed
Status: newclosed

Thanks for your feedback!

This has been fixed now, hopefully for good :)
The screen drawing code has some differences from the original.
This resulted in cases such as this one, where a cutscene was shown (using rat-on-wheels on wife), and then room animations (like the storekeeper's wife) were updated. After a cutscene is finished, the screen refreshes, so the wife's first animation frame was drawn once before the game logic hid it.

We now toggle animation frames in cases where they were done before cutscenes start, which fixes the actual issue.

The fix has been done in commit 774016275e52e6525fd8807ebfb98178a293effb, and will be available in the next daily build of ScummVM:
https://github.com/scummvm/scummvm/commit/774016275e52e6525fd8807ebfb98178a293effb

Closing as fixed

Note: See TracTickets for help on using tickets.