Opened 3 years ago

Closed 4 months ago

#12594 closed defect (wontfix)

AGS: Heroine's Quest is using strange keyboard layout for Russian language input

Reported by: lolbot-iichan Owned by: tag2015
Priority: low Component: Engine: AGS
Version: Keywords: Original
Cc: Game:

Description

NOTE: This is an original bug reproduced without ScummVM.

TESTCASE:

  1. Get https://store.steampowered.com/app/283880/Heroines_Quest_The_Herald_of_Ragnarok/
  2. Select Russian language
  3. Start a new game, you will be asked to input Heroine's name
  4. Switch to Russian keyboard and type "QWERTYUIOP-ASDFGH"

EXPECTED RESULT:
Text "ЙЦУКЕНГШЩЗ-ФЫВАПР" is displayed

ACTUAL RESULT:
Text "УЧЕРТЙЮИОП-АСДФГХ" is displayed, something similar to a transliteration of corresponding English letters.

Change History (5)

comment:1 by dreammaster, 3 years ago

Priority: normallow

Marking these as low priority, since they're existing issues in the stand-alone interpreter. This should make it easier to keep track of upstream problems vs ones introduced in ScummVM

comment:2 by Crystal-Shard, 22 months ago

Hi there, I'm the author of Heroine's Quest. This is an issue within HQ, not within SCUMMVM. Back when HQ was created, the AGS engine did not support Unicode or non-English keyboards, so the translation indeed works by transliteration. As the game is point-and-click and has barely any text entry, this is not a high priority fix for us.

comment:3 by tag2015, 4 months ago

We could probably close this bug, since I don't think we can do much from ScummVM's side.
Radiant, do you need this bugreport open to keep track?

in reply to:  3 comment:4 by Crystal-Shard, 4 months ago

Replying to tag2015:

We could probably close this bug, since I don't think we can do much from ScummVM's side.
Radiant, do you need this bugreport open to keep track?

Thanks for asking. No, we have an internal bug list for that.

comment:5 by tag2015, 4 months ago

Owner: set to tag2015
Resolution: wontfix
Status: newclosed

Ok, closing as wontfix

Note: See TracTickets for help on using tickets.