Opened 8 months ago

Closed 7 months ago

#12589 closed defect (fixed)

AGS: MMM - Episode 8 hangs at the final cutscene

Reported by: NuclearNemo Owned by: dreammaster
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

This report is about a freeware AGS mini game (MMM - Episode 8) that can be downloaded here:
https://www.maniac-mansion-mania.com/index.php/en/spiele/episoden/staffel-1/26-episode-8-die-abfuhr.html

The final cut scene at the end of the game hangs/aborts and the game can't be completed.

How to reproduce:

  • Start game
  • Load attached saved game
  • Use recorder with cassette
  • Go to the kitchen (go through room door, then always keep left)
  • Open window
  • Use recorder with record on it with open window

Then watch the cutscene. After Klaus goes to the garden, Bernard tries to get back to the trap, but just stops at the door and stays there forever (see attached screenshot), so the cutscene is basically aborted. (If you click left, the mouse cursor becomes visible and you can walk through the house, but you can't end the game since the game is intended to end after that cutscene.)

Further information:
ScummVM 2.3.0git (May 25 2021 19:27:09)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL (with shaders) GLEW

Language of game: both english and german are affected.

OS: Kubuntu 21.04

Attachments (2)

Bildschirmfoto_20210525_203034.png (29.9 KB ) - added by NuclearNemo 8 months ago.
Screenshot
mmm8.101 (441.7 KB ) - added by NuclearNemo 8 months ago.
Save game

Download all attachments as: .zip

Change History (3)

by NuclearNemo, 8 months ago

Screenshot

by NuclearNemo, 8 months ago

Attachment: mmm8.101 added

Save game

comment:1 by dreammaster, 7 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Fixed. It seems to be a problem in the stand-alone version as well. The MoveChracterBlocking method is currently a void return, but the game script expects it to be an int that returns a non-zero value if it completes. Since no other games should (I presume) expect any return value, it was a simple fix to change the method to return 1.

https://github.com/scummvm/scummvm/commit/487039489a01e8f72ddf5570429fec6598c2f8bc

Note: See TracTickets for help on using tickets.