#12566 closed defect (fixed)

PRIVATE: Duplicate Inventory in Casebook

Reported by: TrivialBalderdash Owned by: neuromancer
Priority: low Component: Engine: Private
Version: Keywords:
Cc: Game: Private Eye

Description

When viewing the inventory in the casebook, there are duplicate items listed and the list goes off the page (see attachment). Some are listed two or three times. There also appears to be a blank line at the top, or the list starts a line below where it does on original hardware.

Note: In the right screenshot there are two matchbooks. This is not a duplicate, as there are two different matchbooks in the game.

I wasn't able to collect enough inventory on the to see if the list would normally go off the page without duplicates. It looks like there are about 18 lines, but game.dat lists 21. Maybe it's not possible to collect them all at the same time.

Attachments (2)

Inventory List.png (1.0 MB ) - added by TrivialBalderdash 13 months ago.
Inventory List 2.png (1.6 MB ) - added by TrivialBalderdash 13 months ago.

Change History (5)

by TrivialBalderdash, 13 months ago

Attachment: Inventory List.png added

comment:1 by neuromancer, 13 months ago

Interesting. I was already aware that the game allow you to add duplicated items in the inventory, so I guess the code in the binary should discard them. Do you know exactly what to do to force a duplication of an item (e.g. drug sales list)?

PS: your side by side screenshots are very useful. Thanks a lot!

comment:2 by TrivialBalderdash, 13 months ago

Thank you for the quick response. I tried to replicate the problem and I think I found the cause. When you reload a save game from the in-game menu, it doesn't clear the inventory list, appending to the list instead. (See new screenshot). I tested this with multiple reloads and ScummVM restarts.

I also noticed that saving a game with a duplicated list will keep the duplicates after quitting ScummVM and reloading the save. (thus, I don't think it's just a display issue.)

by TrivialBalderdash, 13 months ago

Attachment: Inventory List 2.png added

comment:3 by neuromancer, 13 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.